Bug 470044 - Backlight levels are incorrectly set on MacBook Pro 4,1
Backlight levels are incorrectly set on MacBook Pro 4,1
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 08:27 EST by Stewart Adam
Modified: 2009-04-15 11:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 11:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2008-11-05 08:27:05 EST
Description of problem:
On the MacBook Pro 4,1 (early 2008 model), the minimum backlight level is no backlight at all. The screen appears to be off, but if you're in a very dark environment it's possible to faintly make out window shapes.

This is useful for saving power, but gnome-power-manager should not dim the brightness of the screen to that level automatically, for example when the computer has been idle for a few minutes. It also makes resuming from suspend difficult, as it's difficult to tell if the resume failed or if the screen is just very dark. This happens when the computer is idle or suspends near the minimum brightness, so when g-p-m dims the screen, it enters the "no backlight" mode.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.24.1-3.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set the brightness to 1 step from the lowest
2. Get some food
3. Return to the computer and try to unlock it

Actual results:
Screen appears to be off, and you can't raise the brightness because the session has also been locked.

Expected results:
Backlight level is not automatically reduced to the last step, but the second to last instead.

Additional info:
I'd imagine this is also true for the MacBook and MacBook Air 4,1 as well.
Comment 1 Stewart Adam 2008-11-28 22:35:09 EST
This problem has gotten much worse in F10 final because it now also happens after suspend, and the ambient light sensor seems to be broken and likes to set the LCD backlight to the minimum every few minutes.
Comment 2 Stewart Adam 2009-02-09 18:40:53 EST
A bit better in Fedora 11 Alpha... The LCD backlight levels aren't erratic, but the ambient light sensor now has no effect on the screen's backlight levels.
Comment 3 Richard Hughes 2009-04-15 11:55:17 EDT
Right, if you want to help me with the ambient light sensor, I would appreciate some help on the gnome-power-manager mailing list.

Note You need to log in before you can comment on or make changes to this bug.