Bug 470087 - Federation links do not implement cluster failover
Federation links do not implement cluster failover
Status: CLOSED DUPLICATE of bug 462461
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All All
high Severity high
: ---
: ---
Assigned To: messaging-bugs
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 12:59 EST by Ted Ross
Modified: 2009-05-26 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-17 07:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-11-05 12:59:00 EST
A federation link, where one broker acts as the client of another, will not perform failover if the server-broker is clustered.

Cluster failover needs to be implemented in the broker-as-client similarly to the way it is done in the messaging client implementation.
Comment 1 Gordon Sim 2009-02-17 07:50:50 EST
Treating as duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=462461

Full session-resume functionality for links can be raised as a separate BZ if required (along with justification).

*** This bug has been marked as a duplicate of bug 462461 ***

Note You need to log in before you can comment on or make changes to this bug.