Bug 470094 - crash on shutdown, thinkpad x61
crash on shutdown, thinkpad x61
Status: CLOSED DUPLICATE of bug 464866
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 13:17 EST by Máirín Duffy
Modified: 2009-09-06 05:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 05:23:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.50 KB, text/plain)
2008-11-11 12:47 EST, Máirín Duffy
no flags Details
Xorg log file (79.46 KB, text/plain)
2008-11-11 12:53 EST, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2008-11-05 13:17:48 EST
Description of problem:

If I boot into the kernel-2.6.25-14.fc9.x86_64 kernel, then my x61 shuts down fine.

If I boot into either of the following newer kernels and shut the machine down, it crashes and the display gets filled with junk (kind of staticy grey artifacts):

kernel-2.6.27.4-58.fc10.x86_64
kernel-2.6.27.4-68.fc10.x86_64

As far as I can tell the kernel oops app is not reporting these crashes. It hasn't popped up on this particular machine at all and there are no references to 'kerneloops' in /var/log/messages. I don't see anything particularly suspicious or interesting when these crashes occur in /var/log/messages either.

Let me know if there is some way I can better provide debug information for these crashes.

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-58.fc10.x86_64
kernel-2.6.27.4-68.fc10.x86_64

How reproducible:
Very

Steps to Reproduce:
1. obtain a thinkpad x61 tablet
2. boot into one of the two kernels above
3. shut the machine down
  
Actual results:
crash

Expected results:
clean shut down
Comment 1 Dave Jones 2008-11-11 12:22:17 EST
if you flip to tty2 and run shutdown -h now as root, does it still crash in the same way?

(Trying to get X out of the picture)
Comment 2 Máirín Duffy 2008-11-11 12:44:16 EST
Hi Dave!

Using kernel-2.6.27.4-79.fc10.x86_64, it doesn't crash at all if I shutdown -h as root in tty2.

However, it does indeed crash if:
- I do system > shutdown in gnome
- I hit the 'shutdown' button in GDM

I also noticed that when booted into the F9 kernel, the machine wakes up from suspend fine but it doesn't wake up properly if it's booted into the F10 kernels listed in comment 0 and kernel-2.6.27.4-79.fc10.x86_64 - and the symptom here is that I see a mouse cursor but it's totally frozen and the machine doesn't accept keyboard input.

It does seem like it is related to X, should I move the bug to one of the xorg components (xorg-x11 ?)?
Comment 3 Máirín Duffy 2008-11-11 12:47:56 EST
Created attachment 323208 [details]
xorg.conf

Note that the machine is a tablet so it has a non-typical Xorg.conf, maybe that is contributing to the problem. Here it is.
Comment 4 Máirín Duffy 2008-11-11 12:53:38 EST
Created attachment 323209 [details]
Xorg log file

Here's a recent Xorg log file from the system from when the crashes happened. Some lines that look interesting from it:

"[mi] EQ overflowing. The server is probably stuck in an infinite loop." 

"[mi] mieqEnequeue: out-of-order valuator event; dropping."

I'm not sure if these were the result of the system crash (I'm assuming the system crashed because the thinkpad caps lock key flashes and the system stops responding when it happens) or if they were a result of a failure to wake up after suspend, though.
Comment 5 Bug Zapper 2008-11-25 23:49:45 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 François Cami 2009-05-26 12:59:13 EDT
  Máirín,

Does this happen on F11 ?

Thanks

---
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Máirín Duffy 2009-06-18 14:22:57 EDT
I'm not sure if it will happen in F11 yet. I upgraded to F11 last week, but I've removed my xorg.conf for now. This means my tablet is no longer pressure sensitive. I will try to add my xorg.conf back and see if the problem still occurs or not.
Comment 8 Vedran Miletić 2009-09-06 05:23:02 EDT
This is likely a duplicate.

*** This bug has been marked as a duplicate of bug 464866 ***

Note You need to log in before you can comment on or make changes to this bug.