Bug 470120 - registration number validation fails when calling registration.new_system server call
registration number validation fails when calling registration.new_system ser...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bryan Kearney
Red Hat Network Quality Assurance
us =59467
:
Depends On:
Blocks: 249127 474175
  Show dependency treegraph
 
Reported: 2008-11-05 15:52 EST by Pradeep Kilambi
Modified: 2013-01-10 04:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-28 14:53:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2008-11-05 15:52:52 EST
Description of problem:
When client passes the registrationNumber through s.registration.new_system to hosted, it works the first time but fails in subsequent attempts. Apparently this was new code thats not working appropriately.

How reproducible:
always

Steps to Reproduce:
1. Register a RHEL-5.3 client to rhn.redhat.com with a --subscription option
2. the command fails with:

Error Message:
    Attempt to register a system failed
Error Class Code: 16
Error Class Info: Invalid product registration code.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


  
Actual results:
does'nt validate IN

Expected results:
should validate IN correctly
Comment 2 James Bowes 2008-11-06 08:38:56 EST
Prad, rather than fixing the code server side, would you accept a patch to rhnreg_ks to have it follow the same code path as rhn_register? (ie call activate_hardware_info and new_system_user_pass)?
Comment 3 Pradeep Kilambi 2008-11-06 08:57:03 EST
hi James:

Jus thought it would be cleaner to fix it on the server so we don't have to fix multiple client versions. but if you prefer a fix on the client few questions: 

* if we go with new_system_user_pass would it work in conjunction with activation key? or do we have make user/passwd mandatory with --subscription option.

* will we be defaulting to registration_number instead of registrationNumber? so is the older version still available on the server or do you guys need to revert something for that?

* also we'll have to fix this for RHEL-4 as well? which is 4.8 so the fix wont go in for that until mid next year..

I'm ok with either client or server which ever you prefer, as long as it works with existing scenarios.

Thanks,
~ Prad
Comment 4 James Bowes 2008-11-06 09:31:52 EST
Ah, good point about the activation key. So let's keep the fix server-side.

This is going to be a bit more involved than I first thought, however, since registration.new_system is called by rhn_register in rhel 4 and lower, and you can provide one of the old style subscription numbers. We'll need to ensure that whatever changes are made don't break that
Comment 6 Amy Owens 2008-12-10 13:32:51 EST
all set on dev

Note You need to log in before you can comment on or make changes to this bug.