Bug 470143 - mac80211 built-in, causing mysterious errors with compat-wireless
mac80211 built-in, causing mysterious errors with compat-wireless
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 17:16 EST by Hin-Tak Leung
Modified: 2010-01-29 06:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 11:19:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2008-11-05 17:16:48 EST
Description of problem:
compat-wireless (http://linuxwireless.org/en/users/Download) a way of using the latest wireless stack without building a whole new kernel, by replacing 
the whole of wireless stack - which is a bit smaller and easier/quicker to
replace. Sometimes wireless-testing/compat-wireless needs to change mac80211, and this is impossible with fc10 kernels, because mac80211 is compiled-in.

Version-Release number of selected component (if applicable):
kernel-2.6.27.4-79.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. build compat-wireless,
2. make install, make unload, make load
3. mysterious errors or even kernel oops happens.
  
Actual results:
mysterious errors or even kernel oops happens.

Expected results:
The wireless stack + drivers replaced by compat-wireless and have operational wireless networking

Additional info:
fc9 kernels (e.g. kernel-2.6.27.4-24.fc9.x86_64) have mac80211 as a kernel module.

Probably should assign this to John Linville :-).
Comment 1 Hin-Tak Leung 2008-11-05 18:15:19 EST
I looked through koji and found it was removed between 
0.345.rc7.fc10
0.339.rc7.fc10
but the log entry between does not say why.
Comment 2 John W. Linville 2008-11-06 09:08:04 EST
I advised against it for exactly this reason.  The notion was that this would save time during boot and that anyone who could build compat-wireless could just build their own kernel anyway...whatever.  I think it was the wrong decision.
Comment 3 Dave Jones 2008-11-06 11:05:56 EST
lets move it back to modular then.  There's always going to be trade-offs, and I think in this case, the benefits of a marginally slower boot are outweighed by the improved debugging you get.
Comment 4 Hin-Tak Leung 2008-11-06 12:58:20 EST
compat-wireless is considerably easier and quicker to build; particularly in the situation where one wants to try out new changes (and easily revertable, just by
blowing away /lib/module/<version>/updates and then depmod -a), without whole-sale dev kernel. As for slower boot, it is probably marginal compared to per-driver initialization - and some might argue in the opposite - not all machines have wireless cards.
Comment 5 Hin-Tak Leung 2008-11-08 22:46:37 EST
2.6.27.5-88.fc10.x86_64 just available on koji has the mac80211 component 
as module.

change log:

* Wed Nov 05 2008 John W. Linville <linville@redhat.com> 2.6.27.4-83
- Re-modularize mac80211 component (#470143)

Thank you!

Note You need to log in before you can comment on or make changes to this bug.