Bug 470148 - encrypted Physical Volumes show in "Places->Computer"
encrypted Physical Volumes show in "Places->Computer"
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 17:40 EST by James Cassell
Modified: 2009-11-19 12:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-19 12:05:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Cassell 2008-11-05 17:40:02 EST
Description of problem:
In Fedora 9, when encrypted physical volumes disappeared from "Places->Computer" when they were unlocked.  In F10 preview, the encrypted PVs still show up.

Version-Release number of selected component (if applicable):
hal-0.5.12-9.20081027git.fc10.x86_64


How reproducible:
always

Steps to Reproduce:
1. install F10 preview with encryption option
2. go to places->computer
3. see the pv's listed there

or in my case, 
1. upgrade from F9
2. see (unlocked) encrypted pv's listed
  
Actual results:
unlocked pv's still shown

Expected results:
unlocked pv's disappear

Additional info:
Comment 1 Jef Spaleta 2008-11-05 17:54:03 EST
If this is the wrong place to file... its my fault.

I suspect this is some sort of change in hal policy with regard to volume.ignore matching rules..but I haven't tracked it down...and I could be wrong.

-jef
Comment 2 James Cassell 2008-11-06 18:55:44 EST
So, I did some experimenting:

With the F9 live cd, when I "cryptsetup luksOpen" an encrypted PV, it disappears properly.  Strangely, when I tried the same thing with the F10 preview live cd, I got the same results.

Just to be sure that the problem wasn't an anomaly due to my upgrading from F9, I did a clean install (from the DVD) with the encryption option enabled.  On this clean install, the encrypted PV shows up in "computer" even though it shouldn't (and didn't in F9).

It seems that this problem exists when the PV is the same PV that is the root filesystem.  (Or maybe it's any PV that is unlocked on boot, I don't know.)
Comment 3 Bug Zapper 2008-11-25 23:50:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jiří Stránský 2008-12-24 06:51:30 EST
I confirm this. Here's a solution I managed to google up:

Create a file named:
/usr/share/hal/fdi/policy/10osvendor/99-fixed-drives-override.fdi

containing:
<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- --> 

<deviceinfo version="0.2">
<device>
  <match key="@block.storage_device:storage.hotpluggable" bool="false">
    <match key="@block.storage_device:storage.removable" bool="false">
      <merge key="volume.ignore" type="bool">true</merge>
    </match>
  </match>
</device>
</deviceinfo>

Merry Christmas to everyone,
Jiří Stránský
Comment 5 James Cassell 2008-12-26 17:35:56 EST
The work-around in Comment #4 works for me.

Thanks!
Comment 6 Scott Glaser 2009-04-10 20:18:25 EDT
James,
Have you updated your Fedora 10 installation or tried Rawhide to see if this issue still exists? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 James Cassell 2009-04-14 03:08:36 EDT
Ok, I just installed F11-Snap1

The problem still exists here (rawhide), with the packages as of Snapshot 1.  I'll install the updates, and post the specific version number.

currently:
# rpm -qa|grep -i hal-
hal-libs-0.5.12-26.20090226git.fc11.x86_64
hal-info-20090330-1.fc11.noarch
hal-0.5.12-26.20090226git.fc11.x86_64
hal-cups-utils-0.6.19-2.fc11.x86_64
Comment 8 James Cassell 2009-04-14 10:09:36 EDT
the problem still exists in F10, as well.  Additionally, I found that the magical workaround from Comment #4 didn't work _quite_ as well as I had thought.  (It seems to hide all encrypted PVs whether or not they're locked.)
Comment 9 Scott Glaser 2009-09-09 08:13:30 EDT
Have you tried with the latest hal package in Fedora 11 or tried Rawhide? In
either case, can you let us know whether the issue is still happening, and give
the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Bradley 2009-09-09 08:17:01 EDT
Happens with F11:

hal-0.5.12-29.20090226git.fc11.x86_64

Mine is actually an encrypted LV (not a PV), but I assume its the same issue.
Comment 11 Bug Zapper 2009-11-18 03:45:56 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Josh Stone 2009-11-18 13:50:24 EST
F12 doesn't have this issue anymore...
Comment 13 Scott Glaser 2009-11-19 12:05:14 EST
Based on the information in comment #12 I am closing this bug as CLOSED CURRENTRELEASE should you experience this issue again in the future feel free to file a new bug against the appropriate component.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.