Bug 470159 - emacs hangs and outputs error info when dragging mouse 1
emacs hangs and outputs error info when dragging mouse 1
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
9
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-05 21:22 EST by Dave Blackburn
Modified: 2013-01-09 23:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-14 10:07:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Blackburn 2008-11-05 21:22:34 EST
Description of problem:

Emacs hangs and outputs an error message:
Locking assertion failure.  Backtrace:
#0 /usr/lib64/libxcb-xlib.so.0 [0x317640097c]
...
when dragging to select text in a buffer.

Version-Release number of selected component (if applicable):

emacs-el-22.2-5.fc9.x86_64
emacs-22.2-5.fc9.x86_64
emacs-common-22.2-5.fc9.x86_64


How reproducible:

On x86_64 Fedora system:
emacs -q &
and drag to select text.

Steps to Reproduce:
1. emacs -q &
2. drag to select text in initially displayed buffer.
3.
  
Actual results:

Emacs hangs and displays error message

Expected results:

No hang, no error message, text to be selected


Additional info:

Full error message is:
Locking assertion failure.  Backtrace:
#0 /usr/lib64/libxcb-xlib.so.0 [0x317640097c]
#1 /usr/lib64/libxcb-xlib.so.0(xcb_xlib_lock+0x17) [0x3176400af7]
#2 /usr/lib64/libX11.so.6 [0x317604c610]
#3 /usr/lib64/libX11.so.6(XFlush+0x12) [0x3176024d82]
#4 /usr/lib64/libgdk-x11-2.0.so.0(gdk_display_flush+0x98) [0x318044676a]
#5 /usr/lib64/libgdk-x11-2.0.so.0 [0x318043d1e5]
#6 /usr/lib64/libgdk-x11-2.0.so.0(gdk_window_process_all_updates+0xf9) [0x318043d2fc]
#7 emacs [0x48cf93]
#8 emacs [0x48d062]
#9 emacs [0x48d940]
#10 emacs [0x48d9ad]
#11 /usr/lib64/libX11.so.6(_XError+0xf4) [0x3176045524]
#12 /usr/lib64/libX11.so.6 [0x317604cf5f]
#13 /usr/lib64/libX11.so.6(_XReply+0x18a) [0x317604d30a]
#14 /usr/lib64/libX11.so.6(XSync+0x63) [0x3176040db3]
#15 emacs [0x48cf9d]
#16 emacs [0x4a2fbc]
#17 emacs [0x530937]
#18 emacs [0x55ec2a]
#19 emacs [0x532a05]

uname -a
Linux cs5 2.6.25-14.fc9.x86_64 #1 SMP Thu May 1 06:06:21 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

System has almost all current rpms installed.
yum check-update
kernel.x86_64                            2.6.26.6-79.fc9        updates-newkey  
kernel-headers.x86_64                    2.6.26.6-79.fc9        updates-newkey  
kerneloops.x86_64                        0.12-1.fc9             updates-newkey
Comment 1 Dave Blackburn 2008-11-05 22:57:44 EST
Later I observed several emacs processes running w/o a display window:
11254 root      20   0  131m  24m 9876 R 25.3  1.2 182:08.06 emacs                                  
11469 root      20   0  131m  24m 9856 R 25.0  1.2 180:41.90 emacs                                  
13335 trudy     20   0  131m  24m 9836 R 25.0  1.2  62:09.06 emacs                                  
13392 trudy     20   0  131m  24m 9820 R 25.0  1.2  48:09.37 emacs                                  
13589 trudy     20   0  131m  24m 9820 R 25.0  1.2  45:35.75 emacs                                  
13596 trudy     20   0  127m  20m 9800 R 25.0  1.0  45:11.26 emacs                                  
11578 root      20   0  131m  24m 9864 R 24.6  1.2 174:09.46 emacs                                  
13538 root      20   0  130m  23m 9816 R 24.6  1.2  47:59.00 emacs                                  

I killed most of these processes with the default kill signal.
While doing so, two processes changed state to:
ps -Al | grep emacs
0 S   511 13335     1 28  80   0 - 33599 futex_ pts/0    01:02:53 emacs
0 S     0 13538     1 25  80   0 - 33486 futex_ pts/1    00:48:43 emacs
but were only killable using kill -9

Earlier, when the emacs processes were hung so c-x c-c was not usable, I had used the window manager (fvwm) destroy op to kill emacs.
That got rid of the emacs windows but apparently left a process still running.
It looks like one process was left for each test I ran.

I then ran emacs -q & followed by lsof -p <process>.
Next, I caused the failure and ran lsof -p <process> again.
The second time, after the failure, lsof listed one additional loaded lib:
 emacs   29820 root  mem REG 8,8 93416 293917 /lib64/libgcc_s-4.3.0-20080428.so.1
Otherwise, the lsof output was identical.
Comment 2 Dave Blackburn 2008-11-08 13:44:03 EST
I ran the following:
yum erase emacs
yum install emacs-1:22.2-4.fc9.x86_64
yum update emacs

I can no longer reproduce this problem.

Both emacs-1:22.2-4 and emacs-1:22.2-5
work OK.

I reduced the priority to low.
Comment 3 Bug Zapper 2009-06-09 23:11:21 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Bug Zapper 2009-07-14 10:07:32 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.