Bug 470216 - EXT4-fs error (device xvda5): ext4_get_group_desc: block_group >= groups_count - block_group = 1, groups_count = 1
EXT4-fs error (device xvda5): ext4_get_group_desc: block_group >= groups_coun...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.3
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 05:10 EST by Alexander Todorov
Modified: 2009-01-10 11:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-10 10:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/fstab (532 bytes, text/plain)
2008-11-06 05:10 EST, Alexander Todorov
no flags Details
/var/log/dmesg (8.51 KB, text/plain)
2008-11-06 05:10 EST, Alexander Todorov
no flags Details
/var/log/messages (16.96 KB, text/plain)
2008-11-06 05:12 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2008-11-06 05:10:22 EST
Created attachment 322687 [details]
/etc/fstab

Description of problem:
The message in summary is observed in dmesg while system boots

Version-Release number of selected component (if applicable):
kernel-xen-2.6.18-121.el5

How reproducible:
Not sure

Steps to Reproduce:
1. Install PV xen guest on x86_64 with RHEL 5.3 snap #1 using the attached disk layout.
2. Boot the system
3.
  
Actual results:
error message when system boots

Expected results:
no error message

Additional info:
xvda5 is /home
after doing touch /home/test as root the file is created but a message is printed on the console:
JBD: barrier-based sync failed on xvda5 - disabling barriers
Comment 1 Alexander Todorov 2008-11-06 05:10:57 EST
Created attachment 322688 [details]
/var/log/dmesg
Comment 2 Alexander Todorov 2008-11-06 05:12:14 EST
Created attachment 322689 [details]
/var/log/messages
Comment 3 Chris Lalancette 2008-11-06 05:24:17 EST
Well, I'm pretty sure our PV disk implementation doesn't support barriers (we had a long discussion about it a few months back).  Are barriers required for EXT-4 to function?  Also, is EXT-4 going to be supported in 5.3, or is still going to be tech preview?

Chris Lalancette
Comment 4 Alexander Todorov 2008-11-06 06:05:29 EST
ext4 will be tech preview in 5.3. Other questions I can't answer.
Comment 5 Chris Lalancette 2008-11-06 06:12:29 EST
OK, then it shouldn't be a blocker for 5.3.  We'll have to track down what else is going on here; if it turns out we do need barriers, that can be done, it will just have to be 5.4.

Chris Lalancette
Comment 6 Rik van Riel 2009-01-09 20:13:00 EST
ext4 cannot require barriers, because LVM does not support barriers either.

As for what the ext4 message means, maybe Eric Sandeen knows.
Comment 7 Eric Sandeen 2009-01-10 00:32:10 EST
ext4 does not require barriers.

JBD: barrier-based sync failed on xvda5 - disabling barriers

is just telling you that they can't be used.

It's also not the cause of this problem; barriers won't matter 'til you crash and have to replay the logs.

FWIW it's a terribly confusing message.  It should be more like:

ext4_get_group_desc: block_group >= groups_count;  block_group = 1, groups_count = 1

Anyway, fixed upstream by:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=565a9617b2151e21b22700e97a8b04e70e103153

and we'll likely be rebasin ext4 for 5.4 ...  Is this a small, single-bg filesystem?
Comment 8 Rik van Riel 2009-01-10 10:56:06 EST
OK, so all the warning does is tell you the filesystem has only one block group.  I'll drop this one from the kernel-xen bug list.
Comment 9 Eric Sandeen 2009-01-10 11:25:35 EST
Rik, well, it does mark the fs with errors, which is somewhat problematic.  But it's not a terribly big deal other than the "mounting filesystem with errors, fsck recommended" message. A single-bg filesystem is pretty rare too, I think.

-Eric

Note You need to log in before you can comment on or make changes to this bug.