Bug 470233 - RFE: allow firstboot to run system-config-users
RFE: allow firstboot to run system-config-users
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
14
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 07:26 EST by Tom Horsley
Modified: 2013-07-04 08:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: firstboot-1.111-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-18 07:54:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2008-11-06 07:26:56 EST
Description of problem:

I want to create the user on my newly installed system with the same UID
and group that the user had on previous installs so that all the files on
unmodified partitions are still owned by the same user.

Now that f10 conveniently makes it impossible for root to login to gdm,
I can no longer simply skip the user creation page and create the user
later as root.

Instead I am forced to create a dummy user I don't need, just so I can
login as dummy, create the user I really want, then logout and login as
good user and delete dummy user.

If firstboot merely came with an [Advanced...] button on the user creation
page which would run the good old system-config-users program, I could
use it to create my user with the correct UID (and if I wanted more than
one user, I could do that as well).

Version-Release number of selected component (if applicable):
Whatever is on the F10 Preview DVD.

How reproducible:
Every time I install.

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
forced to create useless user

Expected results:
would like to create user with correct UID

Additional info:

Since distro-envy often seems to get more results than common sense,
I'd just point out that OpenSUSE does allow me to create the initial
user and control all the user attributes :-).
Comment 1 Tom Horsley 2008-11-06 10:13:51 EST
I notes this has some overlap with bug 212939, but it seems more
important to do something like this since logging in as root
became impossible (or very convoluted anyway :-).
Comment 2 Chris Lumens 2008-11-06 16:30:33 EST
Yes, I definitely want to rework the firstboot add user module for F11.  In particular I want to add something that lets you add the created user to sudoers, etc.
Comment 3 Andrew McNabb 2009-01-01 15:52:17 EST
I'm having a similar problem.  If I could easily skip the account creation, I would be perfectly happy.  I'm happy to do advanced stuff (like creating accounts with specific UIDs) on the command-line.  Or even better, just have a button to bypass firstboot completely.
Comment 4 Martin Gracik 2010-07-21 08:28:54 EDT
Fixed in version firstboot-1.111-1
Comment 5 Tom Horsley 2010-09-01 14:38:24 EDT
Yep, I was happy to discover the "Advanced" button in my F14 alpha firstboot
that let me run s-c-u and specify all the details of the initial user.

Thanks!
Comment 6 Jan "Yenya" Kasprzak 2010-11-20 18:11:08 EST
In F14, I am able to create users and group using the Advanced button (s-c-u), but firstboot still thinks no users has been created yet, and does not allow me to continue unless a trick described in bug #543008 is used.

This bug is probably related to bug #474007.

Note You need to log in before you can comment on or make changes to this bug.