Bug 470234 - (kickstart) Installation is unreasonably slow
(kickstart) Installation is unreasonably slow
Status: CLOSED DUPLICATE of bug 472595
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Red Hat Satellite QA List
:
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2008-11-06 07:28 EST by John Hodrien
Modified: 2009-02-24 17:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-24 17:32:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Hodrien 2008-11-06 07:28:49 EST
Description of problem:

Installation takes much longer than a normal kickstart.

Version-Release number of selected component (if applicable):


How reproducible:

Everytime.

Steps to Reproduce:
1.  Run a kickstart install without overriding the url

Actual results:

Install takes ages, especially grabbing the headers of the packages while it's preparing to install.  This leads to a very long period before any package has actually been installed.  With a large install this pre-install step can take an hour!

Expected results:

Install should be as snappy as if I wasn't using spacewalk.

Additional info:

This appears to be because all the rpm requests go through a wrapper, so requests go to (for example):

/ty/3K7BjfcP/CentOS/tmpwatch-2.9.7-1.1.el5.1.x86_64.rpm

If I just make available the dvd image that I'd pushed with make-ks-tree.sh directly on the webserver, and point the spacewalk install to it (using the url kickstart parameter) these accesses are no longer wrapped, and the install is *much* faster, and also puts noticeably less load on the server.

If these calls are to be wrapped, they'd better be done so efficiently.
Comment 1 Jan Pazdziora 2008-11-06 07:42:29 EST
Changing Component from Installation (which is really meant to cover installation of the Spacewalk Server) to Server.
Comment 2 Jesus M. Rodriguez 2009-02-24 16:01:20 EST
changed summary to mention kickstart which is different than spacewalk installation.
Comment 3 Jesus M. Rodriguez 2009-02-24 16:06:43 EST
*** Bug 472595 has been marked as a duplicate of this bug. ***
Comment 4 Mike McCune 2009-02-24 17:32:07 EST

*** This bug has been marked as a duplicate of bug 472595 ***
Comment 5 Mike McCune 2009-02-24 17:32:30 EST
I actually was doing all the work in 472595 so I'm closing this one out.

Note You need to log in before you can comment on or make changes to this bug.