Bug 470260 - cluster: use encode/decode for all object replication.
cluster: use encode/decode for all object replication.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.0
All Linux
urgent Severity low
: Next Version
: ---
Assigned To: Ted Ross
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 09:19 EST by Alan Conway
Modified: 2010-10-13 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-13 09:42:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-11-06 09:19:15 EST
Description of problem:

Cluster code uses XML methods to replicate in-memory objects (DeliveryRecord, TxOps etc.) to new members.

The problem is that there's no indication in e.g. the DeliveryRecord code that developers modifying DeliveryRecord won't be aware of the need to also modify the corresponding cluster.xml definition and cluster code.

Solution: 

All objects replicated in the cluster should provide encode/encodedSize/decode,
the cluster will use these rather than XML methods to replicate the objects.

These methods will be present in e.g. DeliveryRecord so developers modifying DeliveryRecord will be more easily able to keep the encode/decode in sync.
Comment 1 Ted Ross 2010-10-13 09:42:44 EDT
This issue will ultimately be resolved by the clustered-queue design work that is ongoing.

Note You need to log in before you can comment on or make changes to this bug.