Bug 470281 - nm-system-settings coredumps with kernel without INOTIFY support
nm-system-settings coredumps with kernel without INOTIFY support
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 10:18 EST by Zdenek Kabelac
Modified: 2009-12-18 01:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:45:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2008-11-06 10:18:07 EST
Description of problem:

hal fails to run with kernel compiled withot INOTIFY.
But also the nm-system-setting generate coredumps
(which is btw not that easy to capture)

[New process 2472]
#0  nm_inotify_helper_add_watch (self=0x0, 
    path=0x7ffb9edaa0c0 "/etc/sysconfig/network") at nm-inotify-helper.c:54
54		g_return_val_if_fail (priv->ifd >= 0, -1);
Missing separate debuginfos, use: debuginfo-install PolicyKit.x86_64 dbus-glib.x86_64 e2fsprogs.x86_64 expat.x86_64 libcap.x86_64 libselinux.x86_64 nss.x86_64
(gdb) bt
#0  nm_inotify_helper_add_watch (self=0x0, 
    path=0x7ffb9edaa0c0 "/etc/sysconfig/network") at nm-inotify-helper.c:54
#1  0x00007ffb9eda6244 in sc_plugin_ifcfg_init (plugin=0x622cc0)
    at plugin.c:567
#2  0x00007ffba029c5ba in IA__g_type_create_instance (
    type=<value optimized out>) at gtype.c:1674
#3  0x00007ffba0280b1b in g_object_constructor (type=140718693145088, 
    n_construct_properties=2677328584, construct_params=0x1) at gobject.c:1334
#4  0x00007ffba0281163 in IA__g_object_newv (object_type=6441952, 
    n_parameters=<value optimized out>, parameters=0x0) at gobject.c:1211
#5  0x00007ffba0281cb7 in IA__g_object_new_valist (object_type=6441952, 
    first_property_name=0x0, var_args=0x7fffaabd8600) at gobject.c:1274
#6  0x00007ffba0281dfc in IA__g_object_new (object_type=6441952, 
    first_property_name=0x0) at gobject.c:1056
#7  0x00007ffb9eda4de1 in nm_system_config_factory () at plugin.c:701
#8  0x0000000000407485 in load_plugins () at main.c:153
#9  main (argc=1, argv=0x7fffaabd8938) at main.c:671

-----

# /usr/sbin/nm-system-settings nm --config /etc/NetworkManager/nm-system-settings.conf

(nm-system-settings:3639): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(nm-system-settings:3639): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed

(nm-system-settings:3639): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed
Segmentation fault (core dumped)

--------
What I do not understand as well is - why is there disabled creation of core files for nm-system-setting execution ?? I'd to create fake script which reenables  ulimit -c unlimited ?


Version-Release number of selected component (if applicable):
hal-0.5.12-9.20081027git.fc10.x86_64

How reproducible:
boot kernel witout INOTIFY
start haldaemon

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
no coredumping, I'm unsure what is so important on the inotify for the whole hal to be unfunctional.

Additional info:
Comment 1 Richard Hughes 2008-11-07 04:56:05 EST
Do we ship any kernels in Fedora or RHEL that don't have inotify enabled?

What does (as root):

service haldaemon stop
/usr/sbin/haldaemon --verbose=yes --daemon=no

...print?
Comment 2 Zdenek Kabelac 2008-11-08 05:58:37 EST
Hmm using Fedora rawhide 2.6.27.4 kernel and having 3d intel graphics so slow, that even software VESA renderer in plain git kernel is twice is fast - I'll think about that later...

Anyway - here is the output of inotify-less kernel


12:37:01.047 [I] hald.c:671: hal 0.5.12
12:37:01.054 [I] hald.c:736: Will not daemonize
12:37:01.055 [I] hald_dbus.c:5417: local server is listening at unix:abstract=/var/run/hald/dbus-7HU1haVGSh,guid=2828f4dfb085640289a54ce1491579dd
12:37:01.061 [E] ck-tracker.c:371: Error doing GetSeats on ConsoleKit: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 0
12:37:01.061 [E] ck-tracker.c:812: Could not get seats and sessions
12:37:01.061 [W] hald_dbus.c:5842: Could not initialize seats and sessions from ConsoleKit
12:37:01.062 [I] hald_runner.c:301: Runner has pid 3200
12:37:01.062 [I] ck-tracker.c:730: ConsoleKit reappeared!
Runner started - allowed paths are '/usr/libexec:/usr/lib64/hal/scripts:/usr/bin'
12:37:01.070 [E] ck-tracker.c:371: Error doing GetSeats on ConsoleKit: org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)
12:37:01.070 [E] ck-tracker.c:812: Could not get seats and sessions
12:37:01.070 [I] hald_dbus.c:5764: In hald_dbus_ck_appeared
12:37:01.070 [E] hald_dbus.c:5512: No computer object?!?
12:37:01.070 [I] device.c:1894: Removing locks from ':1.53'
12:37:01.070 [I] ck-tracker.c:722: uh, oh, ConsoleKit went away!
12:37:01.070 [I] hald_dbus.c:5757: In hald_dbus_ck_disappeared
12:37:01.070 [E] hald_dbus.c:5512: No computer object?!?
12:37:01.070 [I] hald_runner.c:182: runner connection is 0x667730

** (process:3195): WARNING **: Failed to initialize inotify: Function not implemented
12:37:01.070 [W] osspec.c:378: Unable to open /proc/mdstat: No such file or directory
[WARN  3195] polkit-error.c:143:polkit_error_get_error_message(): error != NULL
 Not built with -rdynamic so unable to print a backtrace
*** [DIE] hald.c:main():787 : Could not init PolicyKit context: (null)


btw you could build such kernel yourself for this test...
Comment 3 Bug Zapper 2008-11-25 23:53:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Scott Glaser 2009-09-09 08:15:15 EDT
Have you tried with the latest hal package in Fedora 10, Fedora11 or tried Rawhide? In either case, can you let us know whether the issue is still happening, and give the current version of the HAL packages you're using?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Bug Zapper 2009-11-18 03:46:25 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-12-18 01:45:46 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.