Bug 470327 - ifup eth0 causes link renegotiation and doesn't wait long enough
ifup eth0 causes link renegotiation and doesn't wait long enough
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 13:31 EST by Need Real Name
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-06 14:28:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2008-11-06 13:31:16 EST
Description of problem:

On my Intel Cantiga laptop using e1000e driver, the link negotiation seems to take a long time on certain LANs. The ifup process fails because it resets the link and does not wait long enough for the link to become ready.

Version-Release number of selected component (if applicable):

initscripts-8.85-1 from 10-Preview release

How reproducible:

Not always


Steps to Reproduce:
1. boot computer with LAN cable attached and ONBOOT=yes config
2. LAN isn't ready soon enough
3. eth0 is not configured
  
Actual results:

No net is configured.

Expected results:

Process should wait longer for LAN link and then do DHCP config.

Additional info:

I think this may be an environment where the hardware is having trouble deciding whether to use 1000baseT or 100baseT speeds, so it takes longer.
Comment 1 Bill Nottingham 2008-11-06 14:28:49 EST
You can set LINKDELAY in your ifcfg file to choose a more appropriate delay for your system.

Note You need to log in before you can comment on or make changes to this bug.