Bug 470339 - Postfix does not recognize Dovecot SASL
Postfix does not recognize Dovecot SASL
Status: CLOSED DUPLICATE of bug 470334
Product: Fedora
Classification: Fedora
Component: postfix (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 14:30 EST by John Griffiths
Modified: 2008-11-21 04:52 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-21 04:52:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Griffiths 2008-11-06 14:30:37 EST
+++ This bug was initially created as a clone of Bug #470334 +++
Bug #470334 filed against Fedora 8. This is Fedora 9.

Description of problem:
Postfix does not recognize Dovecot SASL and does not send any emails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Postfix on Fedora 9
2. Configure to use Dovecot SASL
3.try to send email
  
Actual results:
email is held
error in /var/log/maillog (see additional info)


Expected results:
email should be sent

Additional info:
This is not due to selinux; no AVCs.
Happens with postfix-2.5.1-2.fc9 and postfix-2.5.5-1.fc9

Postfix, Dovecot SASL are configured in accordance with http://www.postfix.org/SASL_README.html

/var/log/maillog error:

Nov  6 10:53:37 daniel sendmail[23601]: mA6Frb7N023601: from=root, size=29, clas
s=0, nrcpts=1, msgid=<200811061553.mA6Frb7N023601@daniel.internal.grifent.com>,
relay=root@localhost
Nov  6 10:53:37 daniel postfix/smtpd[23602]: fatal: no SASL authentication mecha
nisms
Nov  6 10:53:38 daniel postfix/master[23594]: warning: process /usr/libexec/post
fix/smtpd pid 23602 exit status 1
Nov  6 10:53:38 daniel sendmail[23601]: mA6Frb7N023601: to=auser, ctladdr=root (0
/0), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30029, relay=[127.0.0.1]
 [127.0.0.1], dsn=4.0.0, stat=Deferred: Connection reset by [127.0.0.1]
Nov  6 10:53:38 daniel postfix/master[23594]: warning: /usr/libexec/postfix/smtp
d: bad command startup -- throttling
Comment 1 Miroslav Lichvar 2008-11-21 04:52:57 EST

*** This bug has been marked as a duplicate of bug 470334 ***

Note You need to log in before you can comment on or make changes to this bug.