Bug 470356 - Can't query Red Hat bugzilla
Can't query Red Hat bugzilla
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-mylyn (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 15:29 EST by Andrew Overholt
Modified: 2009-05-16 12:27 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-16 12:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (5.46 KB, text/plain)
2008-11-06 15:29 EST, Andrew Overholt
no flags Details

  None (edit)
Description Andrew Overholt 2008-11-06 15:29:51 EST
Created attachment 322783 [details]
backtrace

Description of problem:
Can't query Red Hat bugzilla

Version-Release number of selected component (if applicable):
eclipse-mylyn-3.0.3-3.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. start eclipse (clean .eclipse, -clean, whatever)
2. attempt to create a query using the form with Red Hat Bugzilla
  
Actual results:
Timeout (see attached stack trace)

Expected results:
Query items

Additional info:
This apparently works on i386.  Could it be an OpenJDK issue between x86 and x86_64?  I'm running:

$ java -version
java version "1.6.0_0"
IcedTea6 1.3.1 Runtime Environment (build 1.6.0_0-b12)
OpenJDK 64-Bit Server VM (build 1.6.0_0-b12, mixed mode)
Comment 1 Andrew Overholt 2008-11-06 15:30:40 EST
The worst part of this is that 1) the query is uncancellable and 2) my entire workbench hangs after it fails.
Comment 2 Andrew Overholt 2008-11-17 17:39:49 EST
The query does become cancellable and doesn't hang the workbench forever, but the timeout appears to be too long somewhere so it *looks* like it's uncancellable.

I built a new eclipse-mylyn package the other day with a back-ported patch from upstream.  It allows for bugzilla configuration files > 15 MB which b.r.c has.  I'm using it now to work with Red Hat bugzilla.  The initial population of items (products, components, etc.) takes on the order of 10s of seconds for me, but this is a separate upstream bug.  If others could try this build and see if they can work with Red Hat bugzilla, I'd appreciate it:

http://koji.fedoraproject.org/koji/buildinfo?buildID=69400
Comment 3 Bug Zapper 2008-11-25 23:54:49 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Matěj Cepl 2009-05-16 12:27:07 EDT
Cannot reproduce in Fedora 11 with eclipse-mylyn-3.1.0-3.fc11.noarch

I think it can be safely closed now.

Note You need to log in before you can comment on or make changes to this bug.