Bug 470365 - system-config-network is not able to create any new interface
system-config-network is not able to create any new interface
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
: 470442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 16:23 EST by Florian Sievert
Modified: 2009-01-07 04:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 04:06:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Sievert 2008-11-06 16:23:42 EST
Description of problem:
system-config-network is not able to create any new interface. If the user tries to create a new connection, he is able to select the connection type. However, if he clicks on "Forward" nothing happens. If he press cancle, the app is crashing. Because of this nobody is able to create a new xdsl connection that is not detected and managed over networkmanager.

Version-Release number of selected component (if applicable):
1.5.93-2.fc10

How reproducible:
Always

Steps to Reproduce:
1. Start "system-config-network"
2. Click on "New"
3. "Select xdsl connection
4. Press forward
  
Actual results:
Nothing happens, no new connection is created, nor any further informations are asked.

Expected results:
A new dialog appears for connection details.

Additional info:
Starting the application from a terminal gives the following output:

Error in sys.excepthook:              
Traceback (most recent call last):    
  File "/usr/share/system-config-network/netconfpkg/exception.py", line 363, in <lambda>
    progname, version, gui, debug)                                                      
  File "/usr/share/system-config-network/netconfpkg/exception.py", line 285, in handleMyException
    while trace.tb_next:                                                                         
AttributeError: 'NoneType' object has no attribute 'tb_next'                                     

Original exception was:
ImportError: could not import bonobo.ui
Traceback (most recent call last):     
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 811, in on_addButton_clicked
    self.addButtonFunc[self.active_page](button)                                                         
  File "/usr/share/system-config-network/netconfpkg/gui/maindialog.py", line 869, in on_deviceAddButton_clicked
    interface = NewInterfaceDialog(self.dialog)                                                                
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 104, in __init__          
    self.on_start_page_prepare (None, None)                                                                    
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 109, in on_start_page_prepare
    self.druid.set_buttons_sensitive (False, True, True, True)                                                    
AttributeError: '__main__.GnomeDruid' object has no attribute 'set_buttons_sensitive'                             
Traceback (most recent call last):                                                                                
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 123, in on_start_page_next   
    self.druid.append_page(i)                                                                                     
AttributeError: '__main__.GnomeDruid' object has no attribute 'append_page'                                       
Traceback (most recent call last):                                                                                
  File "/usr/share/system-config-network/netconfpkg/gui/NewInterfaceDialog.py", line 123, in on_start_page_next   
    self.druid.append_page(i)                                                                                     
AttributeError: '__main__.GnomeDruid' object has no attribute 'append_page'
Comment 1 Harald Hoyer 2008-11-07 01:48:18 EST
ImportError: could not import bonobo.ui

seems like the package gnome-python2-bonobo is missing or the installation was broken.

what is the output of:
# rpm -V gnome-python2-bonobo 
?
Comment 2 Florian Sievert 2008-11-07 02:26:08 EST
The package is not installed. It was a fresh installation without updating the former system. I might point that I am a KDE user and deselect Gnome Desktop Envroiment during installation. So it might be a wrong dependency.
Comment 3 Harald Hoyer 2008-11-07 02:41:58 EST
ok, then I have to add more dependencies to system-config-network
Comment 4 Harald Hoyer 2008-11-07 03:27:01 EST
*** Bug 470442 has been marked as a duplicate of this bug. ***
Comment 5 Dean Mander 2008-11-07 03:44:44 EST
I confirm, after manual install of gnome-python2-bonobo the problem is fixed.
Comment 6 José Tiburcio Ribeiro Netto 2008-11-12 14:20:15 EST
Me too. I have installed fc10 with KDE Environment and I was having the same problem. It got fixed with the installation of gnome-python2-bonobo.
Comment 7 Bug Zapper 2008-11-25 23:55:02 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Kyle Pablo 2008-12-02 15:20:18 EST
I did a fresh install of F10 with only KDE.  Installing gnome-python2-bonobo fixed the problem.
Comment 10 Fedora Update System 2008-12-17 07:57:49 EST
system-config-network-1.5.95-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/system-config-network-1.5.95-1.fc10
Comment 11 Fedora Update System 2008-12-21 03:24:28 EST
system-config-network-1.5.95-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-network'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11472
Comment 12 Fedora Update System 2009-01-07 04:06:09 EST
system-config-network-1.5.95-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.