Bug 470371 - Anaconda GUI video corrupt, freezes
Summary: Anaconda GUI video corrupt, freezes
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810
Version: 10
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-11-06 22:03 UTC by Leon Stringer
Modified: 2018-04-11 12:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-21 14:14:26 UTC


Attachments (Terms of Use)
Photo of corrupt screen (89.48 KB, image/jpeg)
2008-11-06 22:03 UTC, Leon Stringer
no flags Details
Output from lspci on Fedora 9 partition (1.27 KB, text/plain)
2008-11-07 21:10 UTC, Leon Stringer
no flags Details
Xorg log (26.26 KB, text/plain)
2008-11-09 21:21 UTC, Leon Stringer
no flags Details

Description Leon Stringer 2008-11-06 22:03:50 UTC
Created attachment 322790 [details]
Photo of corrupt screen

Description of problem:
When I try to install F10 Preview, when the Anaconda GUI screen loads, I typically get a corrupt display. I can make out the wizard, the mouse pointer moves but the GUI controls are unresponsive.

Other times I have got a blank screen or a Fedora background (i.e. a sort of splashscreen) with the computer locking up.

I've tried adding 'nomodeset' to the string at boot.

I had the same problem with F10B.

I realise there are a lot of video issues right now but this doesn't seem to fit with any of them.

Version-Release number of selected component (if applicable):
Fedora 10 Preview

How reproducible:
I never get a working install wizard so it's 100% reproducible.

Steps to Reproduce:
1. Booted from F10 Preview DVD
2. Skipped disk check (previously checked)
3. Anaconda GUI starts to load
  
Actual results:
Corrupt video and unresponsive GUI.

Expected results:
Working install wizard.

Additional info:
System is an Intel D845GERG2 board, I'm using the on-board video controller.

Comment 1 Will Woods 2008-11-07 17:24:33 UTC
Intel video doesn't use modesetting (yet) so 'nomodeset' won't do anything.

If you hit Ctrl-Alt-F2, do you get a text console? If so, could you please attach the output of 'lspci' and a copy of /tmp/X.log?

Comment 2 Leon Stringer 2008-11-07 21:10:05 UTC
Created attachment 322898 [details]
Output from lspci on Fedora 9 partition

Comment 3 Leon Stringer 2008-11-07 21:12:53 UTC
I don't get a video console on Ctrl-Alt-F2 but I've got an existing Fedora 9 partition on the same system so I've attached the lspci output from that.

Also, I lost X video when I upgraded F9 to 2.6.25.14-108. This was fixed by 2.6.26.6-79 (see https://bugzilla.redhat.com/show_bug.cgi?id=459437).

(And rhgb has never worked reliably from F9 onwards).

Comment 4 Matěj Cepl 2008-11-08 00:19:08 UTC
Try to install in the text mode (instead of just "linux" on the anaconda command line, write "linux text") and then either X will automagically start up, or if they don't add 3 on the kernel command line and in the text session as normal user (not root), run command startx. Either way should generate /var/log/Xorg.0.log file. Then please attach your X server config file (/etc/X11/xorg.conf, if you have any) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 5 Leon Stringer 2008-11-09 21:21:31 UTC
Created attachment 323027 [details]
Xorg log

Comment 6 Leon Stringer 2008-11-09 21:23:07 UTC
I installed in text mode, ran startx and X attempted to start but I just saw the herringbone default background and the system locked up. The Xorg.0.log file is attached, there is no xorg.conf file.

Comment 7 Bug Zapper 2008-11-26 04:55:16 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 Bob Arendt 2009-03-08 16:31:11 UTC
This could be the same as
Bug#469292 -  Xorg drv-i810 locks up unless NoAccel True
Same intel chipset according to the the lspci.  Bug#469292 is currently reporting against rawhide as well (issues still exist).

BTW - does it work with an xorg.conf , and NoAccel set?  Not an acceptable work-around IMHO (very slow), but it would indicate that they're the same bug.

Comment 9 Vedran Miletić 2009-09-06 08:48:20 UTC
Reporter: is this still an issue on Fedora 11 and/or Fedora 12 Snap1?

Comment 10 Vedran Miletić 2009-09-21 14:14:26 UTC
Reporter doesn't reply. There is a great chance this was fixed in Fedora 11, since intel video driver was quite broken in Fedora 10. Closing as there is no sufficent data to work on this or to forward this upstream, and it wasn't retested recently enough to see that this is still an issue.

Reporter, please reopen if you can reproduce this.


Note You need to log in before you can comment on or make changes to this bug.