Bug 470372 - Certification with Infiniband HCA MT25204
Certification with Infiniband HCA MT25204
Status: CLOSED WORKSFORME
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 17:05 EST by fusion1200
Modified: 2014-03-25 20:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-27 13:02:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fusion1200 2008-11-06 17:05:48 EST
Description of problem:
The motherboard is a X7DWT-INF with infiniband onboard. 
The infiniband is detected as network.
  
Version-Release number of selected component (if applicable):

How reproducible:
running the hts run --server xxx.xxx.xxx.xxx with a system with an Infiniband HCA MT25204 

Steps to Reproduce:
1. hts run --server xxx.xxx.xxx.xxx 
  
Actual results:
Cannot get device settings: No such device 
Cannot get wake-on-lan settings: No such device 
Cannot get message level: No such device 
Cannot get link status: No such device 

Expected results:
should be not tested with the gigabit network. the Infiniband HCA MT25204 dont support the same feature that the gigabit network

Additional info:

Thanks 

Gilles Therrien
Comment 1 YangKun 2008-11-06 21:32:00 EST
Hi,

In order to test InfiniBand HCAs, you need to configure IPoIB first(after the IPoIB is properly configured, the Infiniband HCAs will be treated as normal ethernet NICs by HTS), then run the "hts plan", hts will detect these new NICs. and then you can run the NETWORK test on these HCAs. the simple steps are:

1) run "hts clean" to clear previous logs, please backup if necessary;
2) configure the IPoIB;
3) make sure the new IPoIB devices "ibX" is up and running;
4) run "hts plan"
5) run the NETWORK test


please refer to following comments on how to configure IPoIB:
-------------------------------------------------------------
IPoIB (IP over IB): While Infiniband HCAs are designed to utilize Infiniband's
own software stack, they can also support TCP/IP traffic using IPoIB protocol.
You must configure an Infiniband HCA just like an NIC card for this. Generally,
the naming convention for Infiniband HCAs is ibX.

Basically, for the IPoIB capability, you write an interface file , just like
you'd do for ethernet interfaces, such as:
# cat /etc/sysconfig/network-scripts/ifcfg-ib0
IPV6INIT=no
ONBOOT=yes
USERCTL=yes
PEERDNS=no
TYPE=Infiniband
DEVICE=ib0
BOOTPROTO=none
NETMASK=255.255.255.0
IPADDR=192.168.1.32

Make sure that the device name is prefixed with ib . And then you can use the
regular ifup/ifdown commands to bring it up. Of course, before doing this,
Infiniband HCAs should be up and their modules need to be loaded. In RHEL5 we
have openibd init script do the job. So, service openibd status would show the
status. Lastly, in at least one of the nodes opensmd deamon must be running
which also has an init script named opensmd.
-------------------------------------------------------------

Thanks
-YK
Comment 2 fusion1200 2008-11-07 10:36:36 EST
Hi,

the infiniband pass the test.
How do I specify 2 ip for the hts server since we have 2 Gigbit nic and 1 infiniband?
The infiniband is not on the same network that the gigabit.

Thanks

Gilles Therrien
Comment 3 YangKun 2008-11-09 20:44:49 EST
Hi Gilles,

Currently, HTS does not support multiple network testing servers. You can separate the testing for Infiniband HCAs and the normal ethernet NICs by removing some of the cards from the systems.

But if you can not separate these devices. You can just run the network test like this:
    1) to test normal ethernet NICs first
        # hts certify --test network --server ETHERNET.SERVER.IP.ADDRESS
    2) then test the the Infiniband HCAs
        # hts certify --test network --server INFINIBAND.SERVER.IP.ADDRESS

Please notice that in this way, some of the tests during the network testing will fail while others may pass(For example, the normal ethernet NICs will fail while testing the Infiniband HCAs and vice versa), which leads to the final "error" exit status. These testing results are ok for us. We'll manually verify them. But please remember to tell our reviewers what's in the result package you're uploading(what devices been tested).

Thanks
-YK

Note You need to log in before you can comment on or make changes to this bug.