Bug 470389 - cannot use UID and GID entries for configuration channels
cannot use UID and GID entries for configuration channels
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Matthews
Red Hat Satellite QA List
:
Depends On:
Blocks: space04
  Show dependency treegraph
 
Reported: 2008-11-06 17:59 EST by John Matthews
Modified: 2009-01-22 11:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 11:30:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2008-11-06 17:59:59 EST
Satellite bug #433712

Description of problem:
cannot use UID and GID entries for configuration channels
Using a user name or group name works fine; however, using the UID or GID (which the web management interface clearly states is valid) causes "rhncfg-client get" to report these errors.

How reproducible:
Always.

Steps to Reproduce:

1.) In test system created a user "test" with uid "500".
2.) Satellite -> Systems -> <system> -> Configuration -> Add Files -> Create File
   Created a file with path /home/test/test [ tried different combinations ]
   UID and GID were given appropriately.
3.) Published it to Central Config channel as well as system channel
4.) Once done, issued rhncfg-client get

Actual results:

Error occurs: information on user 500 could not be found.

Also tried deploying it and then scheduling from satellite. rhn_check didn't show any message, but History of that system shows the event as failed with the reason

This action will be executed after 2008-02-09 17:15:51 IST.
This action's status is: Failed.
The client picked up this action on 2008-02-09 17:16:02 IST.
The client completed this action on 2008-02-09 17:16:03 IST.
Client execution returned "Failed deployment and rollback, information on user '500' could not be found" (code 50)


Expected results:
The config file should have been deployed.
Comment 1 John Matthews 2008-11-06 18:02:47 EST
http://git.fedoraproject.org/git/?p=spacewalk.git;a=commit;h=4c6d33c69a9e728ef6b6a9b7de48fe6333091ef1

Updated webui to remove the reference to "uid/gid".  This was never supported in the code, when it was ported from Perl to Java, an error was made on the ui to indicate "id" support was added, when it was not intended.  Hence the webui will have the id reference removed.

Note You need to log in before you can comment on or make changes to this bug.