Bug 47039 - HTTP TUI install isn't prepending / to "Red Hat directory"
HTTP TUI install isn't prepending / to "Red Hat directory"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-02 15:01 EDT by Brent Nordquist
Modified: 2007-04-18 12:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-02 16:23:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brent Nordquist 2001-07-02 15:01:05 EDT
Description of Problem:
When doing HTTP TUI install of Fairfax beta1, got an error retrieving
stage1 because the HTTP request didn't have a leading / on the URI.  Adding
"/" to the front of the TUI field fixes it.  There is also a typo on one of
the HTTP TUI dialogs.

How Reproducible:
Consistently.

Steps to Reproduce:
1. Answer questions about language and keyboard type.
2. For [Installation Method] dialog, choose HTTP.
3. For [Configure TCP/IP] dialog, choose:
   [ ] Use dynamic...
       IP address:            172.18.34.16
       Netmask:               255.255.192.0
       Default gateway (IP):  172.18.1.15
       Primary nameserver:    172.18.14.1
4. For [HTTP Setup] dialog, choose:
   Web site name:      172.18.1.28
   Red Hat directory:  fairfax/beta1/i386

Actual Results:
Received dialog [Error] with text:
Failed to retrieve fairfax/beta1/i386/RedHat/base/netstg1.img: Bad FTP
server response.
(a) Note the error says "FTP", should be "HTTP".
(b) Inspecting the Apache access_log finds:
Invalid URI in request GET fairfax/beta1/i386/RedHat/base/netstg1.img HTTP/1.1
(note no leading slash on the path)

Expected Results:
can be had by changing "Red Hat directory" to "/fairfax/beta1/i386" but
many people will probably trip over this.
Comment 1 Matt Wilson 2001-07-02 16:23:54 EDT
should be fixed in CVS, needs testing.
47039

Note You need to log in before you can comment on or make changes to this bug.