Bug 470392 - eats fstab entries on upgrade
eats fstab entries on upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10AnacondaBlocker
  Show dependency treegraph
 
Reported: 2008-11-06 18:09 EST by Bill Nottingham
Modified: 2014-03-16 23:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 17:59:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
old fstab (663 bytes, text/plain)
2008-11-06 18:10 EST, Bill Nottingham
no flags Details
upgraded fstab (830 bytes, text/plain)
2008-11-06 18:10 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2008-11-06 18:09:40 EST
Description of problem:

When doing a luks upgrade, anaconda rewrites fstab and crypttab. (Since it's using a different device naming paradigm than F9, this is probably a good idea.)

However, in doing so, it removes entries that it's not using in the upgrade.

Version-Release number of selected component (if applicable):

rawhide-20081104

How reproducible:

Every time

Steps to Reproduce:
1. Install F9 using luks
2. Upgrade!
Comment 1 Bill Nottingham 2008-11-06 18:10:26 EST
Created attachment 322792 [details]
old fstab
Comment 2 Bill Nottingham 2008-11-06 18:10:46 EST
Created attachment 322793 [details]
upgraded fstab
Comment 3 Chris Lumens 2008-11-10 16:50:32 EST
It only deleted the NFS entry because it's marked as noauto.  Now to figure out why exactly we were doing that...
Comment 4 Chris Lumens 2008-11-12 10:08:32 EST
Well it's not at all easy to preserve those entries with the existing partitioning code, however we can at least make a backup of the fstab so you can restore them yourself later.  Committed a patch to do just that.
Comment 5 Tom "spot" Callaway 2008-11-14 17:38:36 EST
(In reply to comment #4)
> Well it's not at all easy to preserve those entries with the existing
> partitioning code, however we can at least make a backup of the fstab so you
> can restore them yourself later.  Committed a patch to do just that.

Is this fixed in a tagged anaconda?
Comment 6 Jeremy Katz 2008-11-14 17:50:17 EST
Yes -- 11.4.1.58-1 and later
Comment 7 Tom "spot" Callaway 2008-11-14 17:59:05 EST
We should be able to close this out then.

Note You need to log in before you can comment on or make changes to this bug.