Bug 47040 - OpenSSH fails to start
Summary: OpenSSH fails to start
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh
Version: 7.3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-02 19:02 UTC by Wade Minter
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-08-08 17:51:25 UTC


Attachments (Terms of Use)

Description Wade Minter 2001-07-02 19:02:54 UTC
Description of Problem:
/etc/init.d/openssh start dies with:
Starting sshd:execvp: No such file or directory

How Reproducible:
Start SSH vi /etc/init.d/openssh start

Actual Results:
SSH doesn't start

Expected Results:
SSH starts

Additional Information:
This is from a Custom installation with the default groups selected.

Comment 1 Pekka Savola 2001-07-06 21:59:40 UTC
I believe this is probably because sshd is started as 'sshd' not /usr/sbin/sshd, and root's path
does not, for some reason, contain /usr/sbin.

There seems to be a new 'setup' package recently which changelog shows something that probably
fixed the problem, whatever it was.


Comment 2 Glen Foster 2001-07-13 22:07:43 UTC
This defect considered MUST-FIX for Fairfax gold-release.

Comment 3 Nalin Dahyabhai 2001-08-06 22:06:07 UTC
Are you certain this is the version of the package included in RHL?  The init
script uses the full path (/usr/sbin/sshd) when starting the server process, and
it's named "sshd" and not "openssh"....

Comment 4 Wade Minter 2001-08-08 17:51:19 UTC
It was a stock install on a clean disk, but the problem seems to be fixed now. 
Weird.

Comment 5 Nalin Dahyabhai 2001-08-09 22:18:08 UTC
O-kay.  I'll close this as worksforme for now, then.


Note You need to log in before you can comment on or make changes to this bug.