Bug 470402 - liveusb-creator doesn't handle spaces in directory names
liveusb-creator doesn't handle spaces in directory names
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: liveusb-creator (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: kushaldas@gmail.com
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 19:25 EST by Mace Moneta
Modified: 2009-03-08 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-08 21:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
liveusb-creator.log (1.63 KB, text/plain)
2008-11-06 19:25 EST, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2008-11-06 19:25:44 EST
Created attachment 322804 [details]
liveusb-creator.log

Description of problem:

liveusb-creator fails to mount the source iso image, because the director it's in contains spaces in the name.

Version-Release number of selected component (if applicable):

liveusb-creator-3.0-2.fc10.noarch

How reproducible:

Always

Steps to Reproduce:
1. Place an iso image in a directory whose name contains spaces.
2. Run liveusb-creator
3. Observe failure
  
Actual results:

F10-PR-i686-Live.iso selected
Verifying filesystem...
Extracting live image to USB device...
There was a problem executing the following command: `mount -o loop,ro /home/mmoneta/temp/test/Work In Progress/F10-PR-i686-Live.iso /tmp/tmptRLcxt`
A more detailed error log has been written to 'liveusb-creator.log'
LiveUSB creation failed!

Expected results:

Successful creation of a bootable USB stick

Additional info: The liveusb-creator log is attached
Comment 1 Luke Macken 2008-11-06 22:33:49 EST
Fixed in commit 2c6b0f3f0b4f116b513858503a8d62b7bb1b812b.  I plan on pushing out a new release at some point this week[end].
Comment 2 Bug Zapper 2008-11-25 23:56:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Luke Macken 2009-03-08 21:29:18 EDT
This issue should be resolved in version 3.6 of the liveusb-creator.  Please re-open this ticket if you still encounter this problem with the latest version.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.