Bug 470403 - gstreamer-plugins-pulse conflicts with gstreamer-plugins-good
gstreamer-plugins-pulse conflicts with gstreamer-plugins-good
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-pulse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Blocker/F10FinalBlocker
  Show dependency treegraph
 
Reported: 2008-11-06 19:28 EST by Muayyad Alsadi
Modified: 2008-11-07 08:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 08:11:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Muayyad Alsadi 2008-11-06 19:28:21 EST
Description of problem:
while composing livecd based on rawhide of an updated F10
I got
Error creating Live CD : Unable to install: [('file /usr/lib/gstreamer-0.10/libgstpulse.so conflicts between attempted installs of gstreamer-plugins-good-0.10.11-1.fc10.i386 and gstreamer-plugins-pulse-0.9.7-1.fc10.i386', (6, '/usr/lib/gstreamer-0.10/libgstpulse.so', 0L))]

it seems that this package should be dropped because the file is provided by good plugins

Version-Release number of selected component (if applicable):
gstreamer-plugins-pulse-0.9.7-1.fc10.i386
gstreamer-plugins-good-0.10.11-1.fc10.i386


How reproducible:


Steps to Reproduce:
1. yum install gstreamer-plugins-good gstreamer-plugins-pulse
  
Actual results:
conflict

Expected results:
no conflict

Additional info:
I think it can be safely dropped because gst-inspect shows pulsesink without having it installled
Comment 1 Rex Dieter 2008-11-07 07:59:48 EST
confirmed.

gstreamer-plugins-good contains this changelog:
* Thu Oct 23 2008 Lennart Poettering <lpoetter@redhat.com> 0.10.10-6
- Enable the PulseAudio element and make it replace the old
  pulseaudio-plugins-pulse package

Looks like the intentions were good.  I'll see what went wrong.
Comment 2 Rex Dieter 2008-11-07 08:01:32 EST
gst-plugins-good contains:
Provides: gstreamer-plugins-pulse = 0.9.8-1
Obsoletes: gstreamer-plugins-pulse < 0.9.8

which is all good here.  I'll look to get gstreamer-plugins-pulse pkg pulled from f-10/rawhide.
Comment 3 Rex Dieter 2008-11-07 08:11:54 EST
Alrighty, pkg is now EOL'd, 
https://fedoraproject.org/wiki/PackageMaintainers/PackageEndOfLife
blocked from F-10 and F-11/rawhide.

Note You need to log in before you can comment on or make changes to this bug.