This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 470408 - R8169 Gigabit Ethernet doesn't work
R8169 Gigabit Ethernet doesn't work
Status: CLOSED DUPLICATE of bug 460747
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 20:35 EST by Andrig Miller
Modified: 2008-12-09 16:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 16:06:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrig Miller 2008-11-06 20:35:41 EST
Description of problem:

The Gigabit ethernet doesn't work at all.

Version-Release number of selected component (if applicable):

I'm using the latest Rawhide kernel - 2.6.27.4-79 on F10 Preview.

How reproducible:

All the time.

Steps to Reproduce:
1. Just boot, and no workie!
2.
3.
  
Actual results:

No link light, and can't get it to come up through any commands.


Expected results:

Should automatically come up when a cable is plugged into it.


Additional info:

r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
r8169 0000:0a:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
r8169 0000:0a:00.0: setting latency timer to 64
r8169 0000:0a:00.0: unknown MAC (27a00000)
r8169 0000:0a:00.0: no MSI. Back to INTx.
eth0: RTL8169 at 0xffffc2000064c000, 00:1e:ec:b7:43:18, XID 24a00000 IRQ 19
Comment 1 Yanko Kaneti 2008-11-07 01:23:02 EST
Perhaps you could try completely powering down the machine and boot that same kernel again. There were some r8169 reports where this seems to have helped.
Comment 2 Andrig Miller 2008-11-07 14:35:24 EST
I have actually tried that, and nothing is different.
Comment 3 Dave Jones 2008-11-11 12:27:06 EST
kernels 2.6.27.4-86 and higher have backports of the 8169 changes from 2.6.28, which will hopefully resolve this.
Comment 4 Andrig Miller 2008-11-11 17:22:18 EST
So, will the final release of Fedora 10 have that kernel?

Thanks.
Comment 5 Dave Jones 2008-11-11 19:26:41 EST
it will have at least that version, yes. likely something even newer.
Comment 6 Andrig Miller 2008-11-12 17:43:33 EST
Excellent.  The weird thing is, with playing around with other things, I had some repeated reboots to try out some sound configuration options on this same hardware.  Just for grins I plugged the ethernet cable in, and now its working.

It's a mystery, because reboots in the past did nothing.  Oh, well, I'll look forward to the final release and the new kernel.

Thanks.
Comment 7 Bug Zapper 2008-11-25 23:56:23 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 toets 2008-12-02 05:41:35 EST
Running Fedora 10 I experience the same problem. Looks very similair to https://bugzilla.redhat.com/show_bug.cgi?id=444966

I also see the amount of interrupts for this nic going through the roof.
Comment 9 Chuck Ebbert 2008-12-09 16:06:04 EST

*** This bug has been marked as a duplicate of bug 460747 ***

Note You need to log in before you can comment on or make changes to this bug.