Bug 470418 - Fedora 10 Preview and Final Release install fails from a USB hard disk
Fedora 10 Preview and Final Release install fails from a USB hard disk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-06 21:51 EST by Dave Ludlow
Modified: 2009-04-08 15:59 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 15:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Ludlow 2008-11-06 21:51:24 EST
Description of problem:
Fedora 10 Preview install fails from a USB hard disk fails with a dialog titled "Missing ISO 9660 Image" stating:

The installer has tried to mount image #1, but cannot find it on the hard drive.

Please copy this image to the drive and click Retry.  Click Exit to abort the installation.

I have copied the iso to the following location on sdb2:
/fedora/10preview/i386/iso

I have copied the contents of the iso to the following location on sdb2 as well:
/fedora/10preview/i386/os

I provided the above location on sdb2 as the location of the image files earlier in the install.

I attempted to mount the .iso under /mnt/source manually in VT #2 to no avail.

None of the Virtual Terminals give any hints about where the installer is looking unsuccessfully.

Version-Release number of selected component (if applicable):
Fedora 10Preview

How reproducible:
Every time

Steps to Reproduce:
1. Configure GRUB to boot from vmlinuz and initrd.img in the isolinux directory of the F10Preview ISO
2. Follow the directions given in the above "Description of the Problem"
  
Actual results:
Install refuses to complete

Expected results:
Install completes, or at least gives a hint as to where it is looking for the image so I can put it there.

Additional info:
Thanks.  Really; you guys all do an amazing job!
Comment 1 Chris Lumens 2008-11-07 11:13:26 EST
Having both the ISO and the exploded contents in the same directory is probably going to lead to some really weird results.  Can you attach /tmp/anaconda.log from your installation attempt to this bug report so I can see what might be going wrong?
Comment 2 Jérôme G. 2008-11-09 13:19:22 EST
I experienced the same problem:

I'm using the Fedora-10 Preview-DVD i386 iso. This image is in my exteral usb hard drive (fat 32).

First, i've just mounted the iso, copied /isolinux on the /boot/ of my computer, and modified grub.

I've booted on the install from grub, choosed "hard drive", the correct drive  and enter the correct path (/perso/fedora/install) to the iso image.

The program can't find the image... but going back I can see it's looking for /perso/fedora/images.install.img.

So I've copied the iso content on my hard drive, in /perso/fedora/install.
Reboot, instal form hard drive and I gave the path /perso/fedora/install. Anaconda start, but after choosing hard drive and partition for installation, anaconda gave me an the same error as Dave:

The installer has tried to mount image #1, but cannot find it on the hard
drive.


I think anaconda is configured for iso CD and not iso DVD... (perhaps?)
Comment 3 joshua 2008-11-25 15:09:34 EST
I too have the same problem, with the Preview and today with F10 itself.... and not even on USB.

I copy Fedora-10-x86_64-DVD.iso to a partition, boot to anaconda, and point it to a hard drive install from that partition.  It can't find squat.

This works with literally every Fedora up until F10 :-(
Comment 4 Chris Lumens 2008-11-25 15:27:59 EST
There's been a slight modification to how HDISO installs work.  From http://docs.fedoraproject.org/install-guide/f10/en_US/sn-installing-from-harddrive.html:

"In addition the install.img file from within the ISO files must be copied to a directory named images."

The images/ directory must be at the same level as your ISO image.  Note that you don't have to do this if you're booting with a boot.iso.
Comment 5 Doug 2008-11-25 18:51:26 EST
Live image works on usb pen, but I would really like to use the DVD.iso.

I too have a problem with Fedora 10 DVD.iso (both final and preview) on my usb pen. I used the same method that works with Fedora 9, but I get this message: "Device /dev/sdb2 does not appear to contain an installation image."

The method (that works like a charm with Fedora 9!):
Make to fat32 partitions on usb pen.One small for boot.iso and one large for DVD.iso. Boot flag on the small partition. Download DVD.iso. Mount DVD.iso. Copy boot.iso from mounted DVD.iso, and then as root change directory to where the boot.iso is located and perform livecd-to-disk:  #livecd-to-disk boot.iso /dev/sdb1 Finally I copy DVD.iso to /dev/sdb2
and reboot.

Tried it this morning with Fedora 9 (and many other times): Success!
Tried it today with Fedora 10 and earlier with some of the preview versions: Failiure!  


Is there a simple method like this for Fedora 10?
Or could it be that ANACONDA is just not ready for this yet?
Comment 6 Doug 2008-11-29 12:18:55 EST
SORRY. (Of course I meant livecd-iso-to-disk, not livecd-to-disk. ) I have noticed that only ONE partition is needed on the usb pen for Fedora 10 DVD.iso, and that is something new from Fedora 9. You also have to make a directory with the name 'images' and copy 'install.img' and to it , and copy DVD.iso to usb pen, after livecd-iso-to-disk with the 'boot.iso'. Tested it, and it works great!
Comment 7 Mathivanan 2009-02-28 08:11:32 EST
I tried 15hrs but i am not getting resolved for this bug. 
I copied Fedora-10-x86_64-DVD.iso and created the USB bootable disk, and i tried with DVD disc also, i used 8GB pendrive also.
Problem:
1.lot of different errors each time installing the OS.
2.I tried with USB Bootable media... it always needs image#1 where can i load this. Please anyone can tell me how to solve this problem
Comment 8 Dave Ludlow 2009-03-02 07:33:31 EST
Comment #4 was the clue that made it work for me.

The ISO file I use is the standard DVD iso image.  Here is the relevant directory structure on my USB hard drive:

fedora/10/x86_64/iso/Fedora-10-x86_64-DVD.iso
fedora/10/x86_64/iso/images/install.img
fedora/10/x86_64/os/isolinux/initrd.img
fedora/10/x86_64/os/isolinux/vmlinuz

The files in 'images' and 'isolinux' are copied from the .iso file itself.

Here is the grub config I use on my bootable USB hard drive:

title Fedora 10 x86_64 Install
        kernel /fedora/10/x86_64/os/isolinux/vmlinuz
        initrd /fedora/10/x86_64/os/isolinux/initrd.img

I tell the installer that my files are in /fedora/10/x86_64/iso.  The basic difference between F10 and <=F9 is that the images directory is put with the .iso file.

I've done this with standard i386, x86_64, and Fedora Unity x86_64 re-spin without issue; in fact, my primary install method is via USB hard drive.  As far as I'm concerned, this bug is FIXED and can be closed.
Comment 9 Chris Lumens 2009-04-08 15:59:34 EDT
There was definitely another bug about this present in F10, and F11 alpha but it has since been tracked down.  I believe hard drive installs should be working fine for the final release of F11.  Thanks for your testing.

Note You need to log in before you can comment on or make changes to this bug.