Bug 470440 - yum install x264-libs: ERROR with rpm_check_debug vs depsolve
yum install x264-libs: ERROR with rpm_check_debug vs depsolve
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 03:02 EST by D. Wagner
Modified: 2014-01-21 18:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 15:08:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "yum -d 9 -y install x264-libs" (80.28 KB, text/plain)
2008-11-07 03:02 EST, D. Wagner
no flags Details

  None (edit)
Description D. Wagner 2008-11-07 03:02:22 EST
Created attachment 322820 [details]
output from "yum -d 9 -y install x264-libs"

Description of problem:

# yum -y install x264-libs                      
Loaded plugins: dellsysidplugin, downloadonly, fastestmirror, fedorakmod,
              : kernel-module, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna: livna.cat.pdx.edu
 * rpmfusion-nonfree-updates: mirrors.cat.pdx.edu
 * fedora: mirrors.cat.pdx.edu
 * rpmfusion-free-updates: mirrors.cat.pdx.edu
 * rpmfusion-free: mirrors.cat.pdx.edu
 * updates-newkey: mirrors.cat.pdx.edu
 * rpmfusion-nonfree: mirrors.cat.pdx.edu
 * updates: mirrors.cat.pdx.edu
367 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package x264-libs.x86_64 0:0.0.0-0.15.20080613.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package     Arch     Version                   Repository                Size 
================================================================================
Installing:
 x264-libs   x86_64   0.0.0-0.15.20080613.fc9   rpmfusion-free-updates    215 k

Transaction Summary
================================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total size: 215 k
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libx264.so.58()(64bit) is needed by (installed) libquicktime-1.0.2-3.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) ffmpeg-compat-0.4.9-0.47.20080225.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) ffmpeg-libs-0.4.9-0.46.20080225.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) mencoder-1.0-0.94.20080531svn.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) mplayer-1.0-0.94.20080531svn.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) mplayer-gui-1.0-0.94.20080531svn.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) vlc-core-0.8.6i-2.lvn9.x86_64
libx264.so.58()(64bit) is needed by (installed) gstreamer-plugins-bad-0.10.7-1.lvn9.x86_64
Complete!
(1, [u'Please report this error in bugzilla'])


It's 100% reproducible.  Doing a "yum clean all" first doesn't help.  I'm attaching the output of "yum -d 9 -y install x264-libs" in case that's helpful.

# rpm -q x264 x264-libs             
x264-0.0.0-0.12.20080227.lvn9.x86_64
package x264-libs is not installed
# rpm -q -f /usr/lib64/libx264.so.58 
x264-0.0.0-0.12.20080227.lvn9.x86_64
Comment 1 seth vidal 2008-11-07 14:06:35 EST
Can you test yum from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=68060

and let us know if you get the same results?
Comment 2 seth vidal 2008-11-07 15:08:27 EST
found it. Fixed in upstream.

http://yum.baseurl.org/gitweb?p=yum.git;a=commit;h=563f25f55324691a76d120d666c7055f74504284

that git commit should do it.
Comment 3 Fedora Update System 2009-01-12 14:19:57 EST
yum-3.2.21-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc10
Comment 4 Fedora Update System 2009-01-12 14:28:06 EST
yum-3.2.21-2.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/yum-3.2.21-2.fc9
Comment 5 Fedora Update System 2009-02-04 21:18:16 EST
yum-3.2.21-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2009-02-04 21:25:44 EST
yum-3.2.21-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.