This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 470461 - Reusing home directory in firstboot needs improvement
Reusing home directory in firstboot needs improvement
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 05:30 EST by Michal Hlavinka
Modified: 2008-12-09 12:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-09 12:52:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2008-11-07 05:30:30 EST
Description of problem:
If home directory already exists:
1) You get question about reusing home directory without description what operations will be done - does reusing means "recreate new empty directory"?

2) It takes a long time for all operations to finish without any progress bar or at least warning "Can take a few minutes" or something.

3) During these operations system looks like not responding. Yes/no dialog stays on screen with "yes" button pushed. When you move yes/no dialog or switch to other "console" and back, screen is not redrawn - stays empty. With hdd led looking like crazy and no information about operation it can look like heavy swap usage and not responding system.

4) During these operations hard disk is under heavy load. With combination of 1)="what is it going to do?" it makes user really unsure if his/her home directory is not being erased or if some other destructive operation is not running. 


Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. Install fedora with existing home
2. Add user with home directory already existing
3. Click "Yes" for "reuse home directory"
  
Actual results:
scared user

Expected results:
informed user

Additional info:
Comment 1 Chris Lumens 2008-12-09 12:52:11 EST
(1) It means that the newly created user will own the home directory and everything in it.  We won't create a new empty home directory.  Fixed.  This should also take care of the concerns in (4).

(2) Added a dialog saying that the contents of the directory are having permissions updated.  I don't think we can very easily show a proper progress bar, but a wait dialog should suffice to keep people from worrying too much.

(3) I can't really take care of this without a major overhaul of how the UI works, I think.  Hopefully with the text and dialog improvements, people won't be wondering what's going on and start switching around terminals trying to find out.

Note You need to log in before you can comment on or make changes to this bug.