Bug 4705 - Problems trying to mount a nfs (server: linux, client: AIX 4.2)
Summary: Problems trying to mount a nfs (server: linux, client: AIX 4.2)
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-server   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-25 17:57 UTC by rodrigob
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-25 18:29:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rodrigob 1999-08-25 17:57:54 UTC
Tested with: RedHat Linux/i386 6.0 and RedHat Linux/sparc
6.0 (bet it happens on the other archs too)
Kernel: 2.2.11
NFS Package: knfsd-1.2.2-4

Lets suppose linux1.mydomain is a sparc machine, and
linux2.mydomain is an i386 machine.

When it works:

linux1# mount linux2:/home /mnt
linux2# mount linux1:/home /mnt
linux1# mount aix1:/home /mnt
linux2# mount aix1:/home /mnt
aix1# mount aix2:/home/mnt

When it does not work:

aix1# mount linux1:/home /mnt
aix1# mount linux2:/home /mnt

I get the following error message:

aix1# mount linux1:/home /mnt
mount: 1831-010 server linux1 not respondingmount: retrying
linux1:/home

But, as you can see, the service is running:

aix1# rpcinfo -p linux1
   program vers proto   port  service
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100024    1   udp    989  status
    100024    1   tcp    991  status
    100011    1   udp   1000  rquotad
    100011    2   udp   1000  rquotad
    100003    2   udp   2049  nfs
    100021    1   udp   1026  nlockmgr
    100021    3   udp   1026  nlockmgr
    100021    1   tcp   1024  nlockmgr
    100021    3   tcp   1024  nlockmgr
    300019    1   tcp    622
    300019    1   udp    623
    100005    1   udp    873  mountd
    100005    1   tcp    875  mountd
    100005    2   udp    878  mountd
    100005    2   tcp    880  mountd
    100005    3   udp    883  mountd
    100005    3   tcp    885  mountd

And I have all I need on my aix machine:

aix1# rpcinfo -p
   program vers proto   port  service
    100000    4   tcp    111  portmapper
    100000    3   tcp    111  portmapper
    100000    2   tcp    111  portmapper
    100000    4   udp    111  portmapper
    100000    3   udp    111  portmapper
    100000    2   udp    111  portmapper
    100003    2   udp   2049  nfs
    100003    3   udp   2049  nfs
    100003    2   tcp   2049  nfs
    100003    3   tcp   2049  nfs
    200006    1   udp   2049
    200006    1   tcp   2049
    100005    1   udp   1084  mountd
    100005    2   udp   1084  mountd
    100005    3   udp   1084  mountd
    100005    1   tcp   1025  mountd
    100005    2   tcp   1025  mountd
    100005    3   tcp   1025  mountd
    100024    1   udp    733  status
    100024    1   tcp    735  status
    200001    1   udp    739
    200001    1   tcp    745
    200001    2   tcp    745
    100021    1   udp   1125  nlockmgr
    100021    2   udp   1125  nlockmgr
    100021    3   udp   1125  nlockmgr
    100021    4   udp   1125  nlockmgr
    100021    1   tcp   1026  nlockmgr
    100021    2   tcp   1026  nlockmgr
    100021    3   tcp   1026  nlockmgr
    100021    4   tcp   1026  nlockmgr

So, I wonder why I does not work.
Any tips ? Any other test ? Anything else I haven't checked
?
Tkx

Comment 1 rodrigob 1999-08-25 18:07:59 UTC
More information about the tests I performed:

linux1# who
rodrigob pts/0    Aug 25 17:23 (aix1.mydomain)

aix1# showmount -e linux1
export list for linux1:
/home		aix1.mydomain,linux2.mydomain

These are working. No clues about any other test I can perform.

Comment 2 Jeff Johnson 1999-08-25 18:29:59 UTC
Try the latest knfsd-1.4.7 package from Raw Hide. You should probably
also install and run the latest kernel-2.2.11 package because of
the knfsd version specific patches in the kernel.

I suspect what's broken is the (broken!) NFSv3 service that the
knfsd-1.2.2 daemon advertises. You might check in /etc/rc.d/init.d/nfs
and make sure that you are starting rpc.mountd with
	--no-nfs-version 3

Please reopen this bug if the above does not fix your problem.
a


Note You need to log in before you can comment on or make changes to this bug.