Bug 470512 - F10 on ThinkPad T60: some function keys don't work; resume doesn't work
F10 on ThinkPad T60: some function keys don't work; resume doesn't work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 09:18 EST by Amit Shah
Modified: 2009-12-18 01:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 01:46:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amit Shah 2008-11-07 09:18:09 EST
Description of problem:

I downloaded the Preview Release of F10 KDE Live spin, tried it on my Thinkpad T60. The volume keys didn't work, neither did the brightness control ones.

Strange thing was, the suspend key didn't work (Fn+F4), but hibernate worked: Fn+F12.

However, resume from S-T-Disk didn't work; it init'ed the graphics, I saw a blank screen with some "noise" horizontal lines across the screen and that was it. The system was running, but display just remained the same. When I pressed the power button, it went into the shutdown routine and ejected the Live CD.

(BTW, suspend-resume is much faster than my current Kubuntu, so I'm very impressed with that.)

Version-Release number of selected component (if applicable):

F10 Preview Release

How reproducible:

Boot x86_64 preview release live cd on a thinkpad t60 and try function keys and suspend to ram and suspend to disk and resume.

I didn't try shutting the lid to check suspend to ram; I can try and report back.
Comment 1 Amit Shah 2008-11-07 09:20:38 EST
Guess I should mention the display card details: The Thinkpad T60 has an ATI X1400 display card (R500).
Comment 2 Bug Zapper 2008-11-25 23:58:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Amit Shah 2009-08-24 03:17:26 EDT
After switching to gnome from kde most of the keys seem to working (on F11).
Comment 4 Bug Zapper 2009-11-18 03:47:15 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2009-12-18 01:46:50 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.