This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 470525 - Kernels 2.6.9-78+ create an unexpected /proc/xen directory
Kernels 2.6.9-78+ create an unexpected /proc/xen directory
Status: CLOSED DUPLICATE of bug 460984
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel-xen (Show other bugs)
4.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Don Dutile
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 10:20 EST by Trevor Hemsley
Modified: 2008-11-11 10:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-11 10:46:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Trevor Hemsley 2008-11-07 10:20:28 EST
Description of problem:
All kernels since 2.6.9-78 create a /proc/xen directory containing the 'file' 'balloon'. This is true on non-Xen kernels and running without any sort of virtualization product installed or running.

Version-Release number of selected component (if applicable):
kernel-2.6.9-78.EL (and 2.6.9-78.0.1 through 5) and affects smp kernels as well


How reproducible:
Every time

Steps to Reproduce:
1. Install any RH kernel newer than 2.6.9-78
2. Boot it
3. ls -la /proc/xen
  
Actual results:
total 0
dr-xr-xr-x    2 root root 0 Nov  7 15:16 .
dr-xr-xr-x  304 root root 0 Aug 28 21:11 ..
-rw-r--r--    1 root root 0 Nov  7 15:16 balloon

Expected results:
ls: /proc/xen: No such file or directory

Additional info:
Many products, most notably Platform Symphony and VMWare check for the presence or absence of Xen by checking if this directory exists. The presence of this directory on non-Xen aware kernels breaks these checks and unexpected results occur.

Would be nice if a) it didn't do it at all or b) it was optional and invoked by the presence of a kernel parameter at boot to turn it on or turn it off - i.e. 

        kernel /vmlinuz-2.6.9-78.0.1.ELsmp ro root=/dev/vg00/root rhgb quiet noxen
Comment 2 Don Dutile 2008-11-11 10:46:32 EST
Doesn't have the same title, but it is a dupe of 460984,
and the patch has been submitted & built into the next
update (4.8).

See the above bz for a test kernel.

If needed/desired/required pre-4.8, request the z-stream
flags to be set in 460984 which will kick a process off to
have it put into a subsequent 4.7 z-stream update/release.

- Don

*** This bug has been marked as a duplicate of bug 460984 ***

Note You need to log in before you can comment on or make changes to this bug.