This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 470543 - SATA RAID not detected during installation on Intel system with ESB2 - LSI firmware
SATA RAID not detected during installation on Intel system with ESB2 - LSI fi...
Status: CLOSED DUPLICATE of bug 489148
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 11:25 EST by Winfrid Tschiedel
Modified: 2009-03-14 17:30 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 08:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
req. output from dmraid (553 bytes, text/plain)
2008-11-13 09:32 EST, Winfrid Tschiedel
no flags Details
requested output for dmraid (553 bytes, text/plain)
2008-11-21 10:18 EST, Winfrid Tschiedel
no flags Details

  None (edit)
Description Winfrid Tschiedel 2008-11-07 11:25:02 EST
Description of problem:

During installation only /dev/sda and /dev/sdb (RAID1) or
/dev/sda ( RAID0 with 1 disk ) are seen


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Intitialize RAID1 or RAID0 on Intel system with ESB2 and LSI Firmware
2. Start installation
3.
  
Actual results:
During partitioning you see /dev/sdx instead of the mapped device


Expected results:
Installer should use RAID configuration


Additional info:
Seems to be a ESB2 specific problem - 
with RAID0 on Promise TX150 I had no problems
other RAID1 configuration could not be tested - lack of hardware.
Comment 1 Winfrid Tschiedel 2008-11-13 09:32:05 EST
Created attachment 323452 [details]
req. output from dmraid

Hello Heinz,

I am not sure, if the way to get the requested output was the best way (only way). So this error occurred very early ( just after input of the license code ) there is not much help at this time from the system. My first idea was to write the output to USB-Floppy but I was not able to mount. Mounting /dev/mapper/ddf1_......p1 also does not work, so I wrote the output to one of the discs of the RAID1 and retrieved it later with rescur system.
Any easier way to do this ??

Winfrid
Comment 2 Heinz Mauelshagen 2008-11-14 03:52:24 EST
Winfried,

that's fine. The output looks ok, so dmraid handles the mirror configuration alright. Looks like an anaconda issue like bz#470540. Changing component.
Comment 3 Bill Nottingham 2008-11-18 20:55:17 EST
Winfrid - where where you running dmraid that you got that output? Rescue mode? A different install?
Comment 4 Bill Nottingham 2008-11-18 21:06:21 EST
Please test with dmraid-1.0.0.rc15-2.fc10.b
Comment 5 Winfrid Tschiedel 2008-11-19 11:32:41 EST
(In reply to comment #3)
> Winfrid - where where you running dmraid that you got that output? Rescue mode?
> A different install?

rescue mode
Comment 6 Bill Nottingham 2008-11-19 11:37:41 EST
Rescue mode of F10 beta, or  F9?
Comment 7 Winfrid Tschiedel 2008-11-19 11:43:42 EST
(In reply to comment #4)
> Please test with dmraid-1.0.0.rc15-2.fc10.b


fedora-10-preview just has dmraid-1.0.0.rc15-1.fc10,
are there any installation DVD with the new dmraid ?
even my updated fedora 10 has the "old" dmraid.
Comment 8 Winfrid Tschiedel 2008-11-19 11:44:36 EST
(In reply to comment #6)
> Rescue mode of F10 beta, or  F9?

Don't blame me - I think it was f10 preview.
Comment 9 Bill Nottingham 2008-11-19 11:49:57 EST
> fedora-10-preview just has dmraid-1.0.0.rc15-1.fc10,
> are there any installation DVD with the new dmraid ?
> even my updated fedora 10 has the "old" dmraid.

Today's rawhide boot.iso.
Comment 10 Winfrid Tschiedel 2008-11-21 10:14:06 EST
Nope, 
I tried the latest rawhide boot.iso 
but I still see /dev/sda and /dev/sdb instead of 
/dev/mapper/ddf1_...........

There is no problem with fedora 9 install, but with actual kernel same problem as above. Also there is no problem with rhel 5.3 install. 
But here you have already in firstboot the problem that you see /dev/sda and /dev/sdb instead of /dev/mapper/ddf1_...........

TGiF,

Winfrid
Comment 11 Winfrid Tschiedel 2008-11-21 10:18:55 EST
Created attachment 324310 [details]
requested output for dmraid 

fedora 10 even mit newest dmraid does not detect RAID1 on ESB2 with LSI firmware.
Comment 12 Bug Zapper 2008-11-25 23:59:29 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Winfrid Tschiedel 2008-12-01 07:28:03 EST
The error exists still on the official fedora 10 release.
Comment 14 Hans de Goede 2009-01-16 17:10:47 EST
Winfrid,

Can you please retest this with F-10, in combination with these updates.img
files:
http://people.atrpms.net/~hdegoede/updates474399-i386.img
http://people.atrpms.net/~hdegoede/updates474399-x86_64.img

To use this with an i386 install type the following at the installer bootscreen (press <tab> to get to the cmdline editor):
updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img

For an x86_64 install use:
updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img

Please let me know if this resolves the issue for you.
Comment 15 Oliver Mirus 2009-01-17 12:17:31 EST
Hans,

I've tried your update for the x86_64 version of F10, but it did not work for me. My mainboard is an Asus P5E WS Professional also with an ESB2 controller with an attached Raid1 array.

Please, let me know, if you need more information.

Oliver
Comment 16 Hans de Goede 2009-01-17 13:42:06 EST
(In reply to comment #15)
> Hans,
> 
> I've tried your update for the x86_64 version of F10, but it did not work for
> me.

Thats not so good news.

> My mainboard is an Asus P5E WS Professional also with an ESB2 controller
> with an attached Raid1 array.
> 
> Please, let me know, if you need more information.
> 

I'm all out of ideas for now, I'll report back here when further testing is needed.
Comment 17 Oliver Mirus 2009-01-18 07:22:29 EST
Hi Hans,

I've just found out, that one is supposed to add this "updates=http://..." as a kernel option. This was nowhere stated and I guess other people also made the same mistake.
So, I started the F10 installation again and this time network configuration appeared before partitioning and the patch was downloaded. After that the Raid device was correctly detected. I went on installing F10. But when everything was finished and I booted into F10 the first time, I had to find out that the raid device was not used, but only /dev/sdb!

I am curently backing up my data and after that I will convert to software instead of fake-raid. It's simply too much trouble!
Comment 18 Winfrid Tschiedel 2009-01-19 03:40:05 EST
(In reply to comment #14)
> Winfrid,
> Can you please retest this with F-10, in combination with these updates.img
> files:
> http://people.atrpms.net/~hdegoede/updates474399-i386.img
> http://people.atrpms.net/~hdegoede/updates474399-x86_64.img
> To use this with an i386 install type the following at the installer bootscreen
> (press <tab> to get to the cmdline editor):
> updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img
> For an x86_64 install use:
> updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img
> Please let me know if this resolves the issue for you.


Hello Hans,

I suppose the instructions for x86_64 are incorrect :
the correct instructions should be -
updates=http://people.atrpms.net/~hdegoede/updates474399-x86_64.img

but this not my major problem, my computer is behind a firewall and I 
have at that time no network, how can I install the updates using a 
USB floppy / CD / file on harddisk.

Cheers,

Winfrid
Comment 19 Hans de Goede 2009-01-19 04:09:23 EST
(In reply to comment #18)
> (In reply to comment #14)
> > Winfrid,
> > Can you please retest this with F-10, in combination with these updates.img
> > files:
> > http://people.atrpms.net/~hdegoede/updates474399-i386.img
> > http://people.atrpms.net/~hdegoede/updates474399-x86_64.img
> > To use this with an i386 install type the following at the installer bootscreen
> > (press <tab> to get to the cmdline editor):
> > updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img
> > For an x86_64 install use:
> > updates=http://people.atrpms.net/~hdegoede/updates474399-i386.img
> > Please let me know if this resolves the issue for you.
> 
> 
> Hello Hans,
> 
> I suppose the instructions for x86_64 are incorrect :
> the correct instructions should be -
> updates=http://people.atrpms.net/~hdegoede/updates474399-x86_64.img
> 

Correct (oops).

> but this not my major problem, my computer is behind a firewall and I 
> have at that time no network, how can I install the updates using a 
> USB floppy / CD / file on harddisk.
> 

We've got some general instructions on this here:
http://fedoraproject.org/wiki/Anaconda/Updates

Let me know if you need more help.
Comment 20 Winfrid Tschiedel 2009-01-20 08:24:56 EST
Hello Hans,

Current situation is even worse -
the final f10 does not detect the embedded SATA DVD and
if I am attaching my USB floopy 
I get a protection error 7f00:0000

I rechecked SLES11 RC2 if everything else is okay,
and here my installation media is found without any problems.
Looks like we have to postpone this problem to the f11 testing.

Winfrid
Comment 21 Paul 2009-02-11 13:30:51 EST
The instructions for web access to the 64-bit update image is fine for a running system, but not usable as an install parameter for a machine that does not have DHCP available during installation of F10.

> I suppose the instructions for x86_64 are incorrect :
> the correct instructions should be -
> updates=http://people.atrpms.net/~hdegoede/updates474399-x86_64.img
Comment 22 Winfrid Tschiedel 2009-02-19 07:35:19 EST
Hi, 

First I changed the assignment to rawhide, because the error still exists
on fedora 11 Alpha -
but there is one good news, now the sata dvd drive is detected
as embedded SATA DVD drive, so no problems to start the installation.

After entering the kayboard layout drive /dev/mapper/ddf1_..... is 
reported as missing, checking in an alternate screen I saw that 
the mapped raid device was not activated - which I fixed with dmraid -ay -p

But this does not help for the partition setup - 
I get still /dev/sda instead of /dev/mapper/ddf1_.......

PS.: I am on holiday until March 16 ( starting on Feb. 21 )
Comment 23 Hans de Goede 2009-02-19 13:35:25 EST
Thanks for the update.

Rawhide is in a bit of a flux atm, we do have many dmraid fixes in there, so I do hope that things will just work there, once anaconda is somewhat stable. Actually postponing testing till march 16 is fine, then we will hopefully have stabilized anaconda from the rework of the storage code we are doing. Please test again after your holliday and let me know how it goes.

Also have a good holliday!
Comment 24 Winfrid Tschiedel 2009-02-20 02:42:47 EST
Hello Hans,

Just another small update -
the problem that dmraid is not activated and the device in the 
partitioner is seen as /dev/sda exists now also on other SATA Raid platforms
( Promise FastTrak ).
Comment 25 Paul 2009-02-20 17:41:16 EST
Got the download working, it's good to be the domain admin. (i.e.: configured a temporary DHCP for the machine's MAC address)

(In reply to comment #21)
> The instructions for web access to the 64-bit update image is fine for a
> running system, but not usable as an install parameter for a machine that does
> not have DHCP available during installation of F10.
> 
> > I suppose the instructions for x86_64 are incorrect :
> > the correct instructions should be -
> > updates=http://people.atrpms.net/~hdegoede/updates474399-x86_64.img

still no go on recognizing the RAID. Serves me right for trying to use a "bargain" commodity server instead of a nice Dell.
Comment 26 Alberto Patino 2009-03-07 01:31:32 EST
After review Bug 468469 test with F9, F10 and F11alpha (also using the iso image provided by Hans/Joel) I am unable to activate the dmraid set. I think my problem is with dmraid:

Using Crtl-Alt-F2:

sh-4.0# uname -a
Linux localhost.localdomain 2.6.29-0.66.rc3.fc11.x86_64 #1 SMP Thu Jan 29 14:44:32 EST 2009 x86_64 unknown

sh-4.0# dmraid -s
ERROR: isw: Could not find disk /dev/sdb in the metadata
ERROR: isw: Could not find disk /dev/sda in the metadata
no raid disks

sh-4.0# dmraid --version
dmraid version:		1.0.0.rc15 (2008-09-17) debug 
dmraid library version:	1.0.0.rc15 (2008.09.17)
device-mapper version:	4.14.0

sh-4.0# lspci
00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 02)
00:1f.2 RAID bus controller: Intel Corporation Mobile 82801 SATA RAID Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation Device 061e (rev a2)
03:01.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
03:01.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)
03:01.2 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 21)
03:01.3 System peripheral: Ricoh Co Ltd R5C843 MMC Host Controller (rev 11)
03:01.4 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 11)
03:01.5 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 11)
09:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5761e Gigabit Ethernet PCIe (rev 10)
0c:00.0 Network controller: Intel Corporation PRO/Wireless 5300 AGN [Shiloh] 

I don't know why dmraid version id rc15 with no patch...

I'll try to debug dmraid from Live CD...
Comment 27 Alberto Patino 2009-03-09 15:03:53 EDT
I have run F10 Live CD, and I have also installed dmraid src rpm from rawhide repo, after debugging the program dmraid I have narrowed my particular problem:

ioctl function returns serial number for di struct with this:
(gdb) p *di
$16 = {list = {next = 0x63f900, prev = 0x63f900}, path = 0x63f8e0 "/dev/sda", serial = 0x63f930 "090114FC3D00NJG3ZDYD", sectors = 488397168}

and isw disk metadata info has this:

(gdb) p *isw
$25 = {sig = "Intel Raid ISM Cfg Sig. 1.0.00\000", check_sum = 4095911876, mpb_size = 480, family_num = 3938914151, generation_num = 196, 
  error_log_size = 4080, attributes = 2147483648, num_disks = 2 '\002', num_raid_devs = 1 '\001', error_log_pos = 2 '\002', fill = "", cache_size = 0, 
  orig_family_num = 3938914151, filler = {94, 0 <repeats 36 times>}, disk = {{serial = "14FC3D00NJG3ZDYD", totalBlocks = 488397168, scsiId = 0, 
      status = 314, owner_cfg_num = 0, filler = {0, 0, 0, 0}}}}

(gdb) p isw->disk[0]
$26 = {serial = "14FC3D00NJG3ZDYD", totalBlocks = 488397168, scsiId = 0, status = 314, owner_cfg_num = 0, filler = {0, 0, 0, 0}}

(gdb) p isw->disk[1]
$27 = {serial = "14FC3D00NJG3ZJ6D", totalBlocks = 488397168, scsiId = 262144, status = 314, owner_cfg_num = 0, filler = {0, 0, 0, 0}}

the function _get_disk try to match serial number from di->serial ("090114FC3D00NJG3ZDYD") with serial number frow isw->disk[0].serial ("14FC3D00NJG3ZDYD"), but seriial number from ioctl has a 4 byte prefix that causes the problem 

This patch solved my problem:

--- lib/format/ataraid/isw.c.old        2009-03-07 20:58:38.000000000 -0600
+++ lib/format/ataraid/isw.c    2009-03-09 12:44:27.000000000 -0600
@@ -84,12 +84,16 @@
 static struct isw_disk *
 _get_disk(struct isw *isw, struct dev_info *di)
 {
+       size_t serial_len, serial_off;
        if (di->serial) {
                int i = isw->num_disks;
                struct isw_disk *disk = isw->disk;
 
                while (i--) {
-                       if (!strncmp(di->serial, (const char *) disk[i].serial,
+                       serial_off = ((serial_len=strlen(di->serial)) > MAX_RAID_SERIAL_LEN) ?
+                               serial_len - MAX_RAID_SERIAL_LEN : 0;
+
+                       if (!strncmp(di->serial+serial_off, (const char *) disk[i].serial,
                                     MAX_RAID_SERIAL_LEN))
                                return disk + i;
                }

This is the right way to summit this patch?

Thanks for your help
Comment 28 Hans de Goede 2009-03-13 08:29:51 EDT
(In reply to comment #27)
> This is the right way to summit this patch?

No.

Many many thanks for looking in to this, and for the patch though!

Please open a new bug against dmraid, with as Summary "PATCH: ......"

And explain what you were seeing in that bug, and attach your patch there.

Thanks,

Hans
Comment 29 Joel Andres Granados 2009-03-13 08:52:29 EDT
(In reply to comment #27)
> I have run F10 Live CD, and I have also installed dmraid src rpm from rawhide

I have opened https://bugzilla.redhat.com/show_bug.cgi?id=490121 to track the dmraid issue.
Comment 30 Joel Andres Granados 2009-03-13 08:55:55 EDT
A lot of structural changes have gone into anaconda partitioning code. (we are
rewriting the whole thing :)  so stuff that has been discussed here might not
be relevant anymore. I would like to redirect the interested parties to the new
dmraid tracking bug that will have all the dmraid related issues for the new
anaconda.

There are a number of underlying causes to these problems, all of which have
been identified and fixed in rawhide we believe.

Unfortunately rawhide is currently not in a good shape to ask you to test it.
We hope to organize a dmraid test day, within some weeks, where we will ask the
community to test dmraid support in rawhide (the upcoming F-11 development
version).

In the mean time we are closing all the open anaconda dmraid bugs, against a
single master bug, for easier tracking, as all the open bugs have the same
underlying cause (2 bugs in pyblock, which have been fixed).

If you're interested in participating in the test day, please add yourself to
the CC of the master bug, I will add a comment there with a pointer to the
announcement for the test day as soon as the date has been fixed.
Comment 31 Joel Andres Granados 2009-03-13 08:56:26 EDT

*** This bug has been marked as a duplicate of bug 489148 ***
Comment 32 Alberto Patino 2009-03-14 17:30:37 EDT
(In reply to comment #29)
> (In reply to comment #27)
> > I have run F10 Live CD, and I have also installed dmraid src rpm from rawhide
> 
> I have opened https://bugzilla.redhat.com/show_bug.cgi?id=490121 to track the
> dmraid issue.  

Thank you very much for your time, I have updated bug 490121. Now my goal is to debug anaconda so it can also recognize my dmraid set

Note You need to log in before you can comment on or make changes to this bug.