Bug 470545 - (emacs-wl) Review Request: emacs-wl - Wanderlust, an advanced mail client for Emacs
Review Request: emacs-wl - Wanderlust, an advanced mail client for Emacs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Fedora Extras Quality Assurance
:
Depends On: emacs-semi
Blocks: FE-DEADREVIEW
  Show dependency treegraph
 
Reported: 2008-11-07 11:32 EST by Vitaly Mayatskikh
Modified: 2012-06-29 13:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 13:08:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vitaly Mayatskikh 2008-11-07 11:32:53 EST
Spec URL: http://people.redhat.com/vmayatsk/wl/wl.spec
SRPM URL: http://people.redhat.com/vmayatsk/wl/wl-2.15.6-1.fc10.src.rpm
RPM URL: http://people.redhat.com/vmayatsk/wl/wl-2.15.6-1.fc10.noarch.rpm
Description:

Wanderlust is advanced mail client for Emacs. It supports IMAP4rev1, NNTP, POP(POP3[3]/APOP), MH and Maildir protocols. Package contains latest cvs snapshot and a bunch of patches from http://repo.or.cz/w/more-wl.git

This is my first package for Fedora.
Comment 2 Robin Green 2009-09-04 11:57:22 EDT
It pauses during the build and asks me to select a coding system (where UTF-8 is the default). It shouldn't do this - it should just use UTF-8.
Comment 3 Vitaly Mayatskikh 2009-09-18 03:20:50 EDT
Yeah, this appeared after Emacs was changed from version 22 to 23 in Fedora 11. I'm trying to fix the problem.
Comment 4 Vitaly Mayatskikh 2009-09-18 04:41:33 EDT
Packages were updated.
Comment 5 Jens Petersen 2009-10-22 01:22:50 EDT
The spec file should be named emacs-wl.spec.
Comment 7 Jonathan Underwood 2010-04-05 20:13:24 EDT
I started to review this by first doing a build in mock, however that fails:

+ cd /builddir/build/BUILD/wl-2.15.6
+ make LISPDIR=/builddir/build/BUILDROOT/emacs-wl-2.15.6-1.fc14.x86_64//usr/share/emacs/site-lisp PIXMAPDIR=/builddir/build/BUILDROOT/emacs-wl-2.15.6-1.fc14.x86_64//usr/share/pixmaps/wl
emacs -batch -q -no-site-file -l WL-MK -f compile-wl-package \
                /builddir/build/BUILDROOT/emacs-wl-2.15.6-1.fc14.x86_64//usr/share/emacs/site-lisp /builddir/build/BUILDROOT/emacs-wl-2.15.6-1.fc14.x86_64//usr/share/pixmaps/wl
Loading /builddir/build/BUILD/wl-2.15.6/WL-CFG...
Cannot open load file: install
make: *** [elc] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.k61Uqr (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.k61Uqr (%install)
Child returncode was: 1
EXCEPTION: Command failed. See logs for output.
 # ['bash', '--login', '-c', 'rpmbuild -bb --target x86_64 --nodeps builddir/build/SPECS/emacs-wl.spec']
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/mock/trace_decorator.py", line 70, in trace
    result = func(*args, **kw)
Comment 9 Jason Tibbitts 2012-06-29 13:08:07 EDT
It appears that this hasn't built in years, and all of the URLs are dead at this point, so I'm going to close this ticket out.

Note You need to log in before you can comment on or make changes to this bug.