Bug 470553 - Qdiskd not starting in RHEL5.3 BETA
Qdiskd not starting in RHEL5.3 BETA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: cman (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: Lon Hohberger
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 11:46 EST by Daniel Riek
Modified: 2010-10-23 01:44 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:50:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (641 bytes, patch)
2008-11-07 12:52 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Daniel Riek 2008-11-07 11:46:57 EST
From IT 237323:

Description of problem:

Qdisk now is started via cman init script. Starting qdiskd always fail with the following message in /var/log/messages:

   Oct 29 20:02:14 esblade1 qdiskd[6146]: <crit> Specified device /dev/mpath/sas1p1 does match kernel's reported sector size (0 != -1)

The output of mkqdisk -L has looked quite normal, den multipath-device was listed in the first lines, even if as always the two qdisk devices are shown with parameters (Creation date and so on) are the both underlying sd-devices.

Also reformatting the qdiskd device didn't work, also with zero-ing it before and recreating it using mkqdisk.

cluster.conf configuration was done in this way:

  <quorumd device="/dev/mpath/sas1p1" interval="5" log_facility="local4" log_level="4" status_file="/tmp/quorum_state" tko="4" votes="2">
    <heuristic interval="3" program="ping 172.16.128.30 -c1 -t3" score="1"/>
  </quorumd>

How reproducible:

Setup a RHEL5.3 BETA cluster. Start cman and have a look at the line when qdiskd starts. Also have a look on /var/log/messages.

Steps to Reproduce:

See above.

Actual results:

Qdiskd won't start and won't work.

Expected results:

Qdiskd should start and work.

Additional info:

Changing the binary to the one from RHEL5.2 seems to work, but in RHEL5.2 qdiskd only seems to work (does not cman_tool leave or reboot if actual scores fall below min_scores, even if paranoid=1 is defined).
Comment 2 Lon Hohberger 2008-11-07 12:51:20 EST
This happens only when 'device' is used.  On 5.3 beta, 'device' is no longer required in multipath configurations because we added intelligent scanning which avoids multipath slaves.
Comment 3 Lon Hohberger 2008-11-07 12:52:21 EST
Created attachment 322876 [details]
Fix

Correct the logic around block size checking.
Comment 6 Lon Hohberger 2008-11-07 13:31:48 EST
Oh - and remove status_file before going to production. :)
Comment 15 errata-xmlrpc 2009-01-20 16:50:50 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0189.html

Note You need to log in before you can comment on or make changes to this bug.