Bug 470561 - F10: reboot doesn't work with virtio drive
F10: reboot doesn't work with virtio drive
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 12:42 EST by Mark McLoughlin
Modified: 2008-12-24 13:46 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-08 06:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-11-07 12:42:37 EST
It appears that if you boot from a virtio drive, reboot will fail with:

  Boot from Hard Disk failed: could not read the boot disk
  FATAL: No bootable device

Looks like extboot ROM isn't being used on reboot.
Comment 1 Eduardo Habkost 2008-11-11 11:40:16 EST
Seeing this here, too. This is the qemu-kvm command-line used by libvirt:

/usr/bin/qemu-kvm -S -M pc -m 1000 -smp 1 -name f10_32f -monitor pty -boot c -drive file=,if=ide,media=cdrom,index=2 -drive file=/mnt/common/images/f10-32f.img,if=virtio,index=0,boot=on -net nic,macaddr=54:52:00:28:57:a6,vlan=0,model=virtio -net tap,fd=12,script=,vlan=0,ifname=vnet0 -serial pty -parallel none -usb -vnc 127.0.0.1:0 -k en-us -soundhw es1370
Comment 2 Fedora Update System 2008-11-24 14:28:29 EST
kvm-74-7.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kvm-74-7.fc10
Comment 3 Bug Zapper 2008-11-26 00:00:03 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2008-11-26 01:10:23 EST
kvm-74-7.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kvm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/f10/FEDORA-2008-10225
Comment 5 Fedora Update System 2008-12-02 11:38:47 EST
kvm-74-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kvm-74-8.fc10
Comment 6 Fedora Update System 2008-12-06 23:20:03 EST
kvm-74-8.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kvm'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-10806
Comment 7 Mark McLoughlin 2008-12-08 06:21:29 EST
I'm not sure what happened here, but it seems to be working fine even with kvm-74-5.fc10.i386

Please re-open if you see this issue with a F10 or later version of kvm
Comment 8 Fedora Update System 2008-12-22 14:46:42 EST
kvm-74-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/kvm-74-10.fc10
Comment 9 Fedora Update System 2008-12-24 13:46:59 EST
kvm-74-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.