Bug 470563 - F10: virt-manager prominently advertises unavailable paravirtualization guests
F10: virt-manager prominently advertises unavailable paravirtualization guests
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10Target
  Show dependency treegraph
 
Reported: 2008-11-07 12:50 EST by Mark McLoughlin
Modified: 2008-12-07 15:03 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 20:25:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2008-11-07 12:50:28 EST
If you go to create a new guest you get:

  Choose a virtualization method:

    [ ] Paravirtualized:

        Blah blah ... better performance than fully virt

    [ ] Fully Virtualized:

        Blah Blah ... slower than paravirtualized systems

and the "paravirtualized" option is greyed out.

To me, that screams "The fast virt method is broken, try using this slow KVM thing instead" ...

Clearly that's not on-message :-)

Can we almost entirely disable this screen if there's no xen available, leaving just:

  Choose a virtualization method:

    CPU architecture: ...

    Hypervisor: ...

We really need this fixed for F10, IMHO.
Comment 1 Daniel Berrange 2008-11-07 13:15:59 EST
Given the translation freeze, we can't really change the text, so best option is to just remove the descriptive blurb below the paravirt / fully virt options. We don't hide the choice entirely because it is still relevant for Xenner.

Long term this UI will be changed so we don't need these choices at all, virt-manager making all the HV/arch/virt-type  choices based on the OS media
Comment 2 Cole Robinson 2008-11-25 13:31:57 EST
How about just toning down the language a bit in the interim:

From: 
PV: Lightweight method of virtualizing machines. Limits operating system choices because the OS must be specially modified to support paravirtualization. Better performance than fully virtualized systems.

FV: Involves hardware simulation, allowing for a greater range of operating systems (does not require OS modification). Slower than paravirtualized systems.

To:
PV: Lightweight method of virtualizing machines. Limits operating system choices because the OS must be specially modified to support paravirtualization, but yeilds better performance than fully virtualized systems.

FV: Involves hardware simulation, allowing for a greater range of virtual devices and operating systems (does not require OS modification).
Comment 3 Bug Zapper 2008-11-26 00:00:10 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Cole Robinson 2008-12-01 12:59:34 EST
I committed that rewording upstream. Setting to POST.
Comment 5 Fedora Update System 2008-12-01 13:00:42 EST
virt-manager-0.6.0-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/virt-manager-0.6.0-4.fc10
Comment 6 Fedora Update System 2008-12-02 20:25:21 EST
virt-manager-0.6.0-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Osma Ahvenlampi 2008-12-04 03:11:59 EST
I'm not native English speaker, but AFAIK "yeilds" is not a proper English word. s/, but yeilds better performance/. Better performance/;
Comment 8 Cole Robinson 2008-12-04 08:36:44 EST
I think in this case it's correct, though maybe a little awkward. The relevant definitions:

yield Pronunciation (yld)
v. yield·ed, yield·ing, yields
v.tr.
1.
a. To give forth by or as if by a natural process, especially by cultivation: "a field that yields many bushels of corn."
b. To furnish as return for effort or investment; be productive of: "an investment that yields high percentages."
Comment 9 Osma Ahvenlampi 2008-12-04 13:10:36 EST
That would be true if the word used was indeed "yield", but it is "yeild". I really don't see what was wrong with the original expression -- to my eyes, the more significant part was removing the sentence "Slower than paravirtualized
systems." from the description of fully virtualized...
Comment 10 Cole Robinson 2008-12-07 15:03:26 EST
Argh, yes, you are correct. My eyes didn't want me to see the difference :/

However, I agree with the reporter that the text is too cut and dry with its wording, and is not as relevant now as it was when it was first added to virt-manager.

I'll fix the spelling though.

Note You need to log in before you can comment on or make changes to this bug.