Bug 470594 - GRUB failure after kernel upgrade to 79.fc10
GRUB failure after kernel upgrade to 79.fc10
Status: CLOSED DUPLICATE of bug 450143
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
10
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 16:36 EST by Marina Zhurakhinskaya
Modified: 2009-06-01 14:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 14:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marina Zhurakhinskaya 2008-11-07 16:36:26 EST
Description of problem:
After letting PackageKit do the upgrade with the latest packages for Rawhide, my system wasn't booting due to a failing GRUB installation.

Booting with a rescue image for F9, doing
chroot /mnt/sysimage
grub-install /dev/sda
and rebooting fixed the problem.

Reviewing gpk-log showed that the new kernel packages (79.fc10) were installed yesterday. Unlike most other PackageKit updates that are in the Updated category, the kernel updates are in the Installed category. I still have 68.fc10 kernel packages installed on the system alongside 79.fc10 packages.

Version-Release number of selected component (if applicable):
kernel 79.fc10

How reproducible:
Don't know if it would show up after updates on other systems.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
system doesn't boot, GRUB failure

Expected results:
system boots

Additional info:
Comment 1 Bug Zapper 2008-11-26 00:00:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michael Schwendt 2009-05-31 14:14:12 EDT
What "GRUB failure"? What did you see on the screen?

Perhaps the same as described in bug 450143?
Comment 3 Marina Zhurakhinskaya 2009-06-01 13:22:45 EDT
Yes, I was seeing "GRUB _"  (underscore being a blinking cursor) on the screen, just as described in the bug you pointed to. Based on that bug descriptions and suggested solution (booting with a rescue image and running grub-install /dev/sda
), this bug looks like its duplicate.
Comment 4 Michael Schwendt 2009-06-01 14:11:07 EDT

*** This bug has been marked as a duplicate of bug 450143 ***

Note You need to log in before you can comment on or make changes to this bug.