Bug 470620 - Logging in to XMPP accounts fails
Logging in to XMPP accounts fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: empathy (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 19:58 EST by Ben Gamari
Modified: 2008-11-08 08:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 08:42:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug log from gabble (12.40 KB, text/plain)
2008-11-07 23:21 EST, Ben Gamari
no flags Details

  None (edit)
Description Ben Gamari 2008-11-07 19:58:57 EST
Description of problem:
Empathy fails to log into both my XMPP and Jabber accounts with a generic "Network Error." I've been unable to get any more debugging information from Empathy. I definitely understand keeping technical error messages hidden away from everyday users, but this is ridiculous. At least dump something to stderr.

Version-Release number of selected component (if applicable):
2.24.1-1.fc10

How reproducible:
Every time.
Comment 1 Brian Pepple 2008-11-07 20:08:53 EST
Ben, could you run the following in a terminal:

GABBLE_PERSIST=1 LM_DEBUG=net GABBLE_DEBUG=all /usr/libexec/telepathy-gabble
2>&1 | tee gabble.log

and then start up Empathy, and try to connect to the jabber server.  The log from this should give me a better idea why this isn't working.  Thanks.
Comment 2 Ben Gamari 2008-11-07 23:21:17 EST
Created attachment 322928 [details]
Debug log from gabble

Hope this helps.
Comment 3 Brian Pepple 2008-11-07 23:58:33 EST
Glancing at the log, it looks like your account information is incorrect.

Your Login Id should be your gmail address, not just your username.  Also, under the Advanced section check the "Encryption required (TLS/SSL)" and "Ignore SSL certificate errors", and uncheck the "Use old ssl"

Make those changes, and see if you can connect.
Comment 4 Ben Gamari 2008-11-08 07:03:47 EST
Note, in my original description of the bug, I intended to write "GTalk" and "XMPP" (not XMPP and Jabber, apparently I was tired last night).

Anyways, after failing to get success by modifying the GTalk account, I deleted it and recreated it and now I can successfully login. Sorry about the noise, I definitely should have noticed the incorrect username. As is expected (I think?) old SSL is still required for GTalk.

Regardless, I would still argue that error reporting is sorely lacking in Empathy. For a program with so many potential points of failure (poor connection, down server, incorrect login information), the error messages really need to be better than a generic "Network Error," especially when the problem is in fact a login failure. This is downright misleading.

Nevertheless, I'm going to try switch to using empathy as my primary client in hopes that soon it will be adequate to use as the Fedora default. I think it is long overdue that the telepathy architecture replaced pidgin on the desktop.
Comment 5 Brian Pepple 2008-11-08 08:42:04 EST
One of the things the Empathy is working on for GNOME-2.26 is improvements to the accounts dialog which should make it more clear what information to use when setting up a new account.  Anyway, closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.