Bug 470631 - /usr/bin/pup crashes
/usr/bin/pup crashes
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 21:46 EST by Wojciech Komornicki
Modified: 2008-11-13 11:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-13 11:03:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wojciech Komornicki 2008-11-07 21:46:44 EST
Description of problem: /usr/bin/pup crashed and left system unstble. Several libraries (librpm-4.4.so, libdb4.6.so) were missing after the crash so restore of system was difficult without a working rpm and sendmail would not start without libdb4.6.so


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2008-11-11 11:12:16 EST
What were you upgrading from/to?
Comment 2 Wojciech Komornicki 2008-11-11 13:51:21 EST
I was running Fedora 9 but after the upgrade /etc/fedora-release was changed to 9.93 (Rawhide)

Each week I run the Software Updater (/usr/bin/pup).  I saw that there was a kernel update and so I chose that by itself, updated the system and rebooted. Re-ran Software Updater and chose all the packages shown to me.  During the update Software Updater crashed creating the log file I posted.  During the recovery process I noticed that my system had been updated to (the pre-release of) Fedora 10.

I did not make a specific choice of updating to Fedora 10 because on this box I was waiting for the stable release.
Comment 3 Jeremy Katz 2008-11-12 17:26:23 EST
How were you running pup on Fedora 9?  In Fedora 9, we moved to the use of PackageKit instead of pup/pirut?
Comment 4 Wojciech Komornicki 2008-11-12 18:20:14 EST
From the launcher I choose Software Updater.  I did notice on a newer installation that Fedora 9 now uses PackageKit. If I notice in Software Updater that I am presented with modules for which a reboot is recommended, I download these on their own, reboot the system and then install the rest.
Comment 5 Jeremy Katz 2008-11-12 20:35:44 EST
How did you install/upgrade to Fedora 9?  pup really shouldn't have been left

And I suspect that the root cause of your problems are API changes in the underlying system that aren't reflected in the old version of pup you had available :/
Comment 6 Wojciech Komornicki 2008-11-13 08:31:22 EST
OK.

Since the crash, I have been using yum in "manual mode" and just recently installed PackageKit with the gnome interface.

Note You need to log in before you can comment on or make changes to this bug.