Bug 470632 - solar-backgrounds-extras should be part of the default CD/DVD media install and should be set as default when manually installed.
solar-backgrounds-extras should be part of the default CD/DVD media install a...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: solar-backgrounds (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Sourada
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-07 21:56 EST by Gideon Mayhak
Modified: 2008-11-16 16:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-16 16:07:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gideon Mayhak 2008-11-07 21:56:59 EST
Description of problem:
solar-backgrounds-extras, an essential package for anyone with a dual monitor setup or any other non-standard display configuration, should be part of the default install on CD/DVD media.  I can understand why it was split off for the live CD, but I feel most people installing from CD/DVD media would expect it to be there by default.

Also, when installed after the fact, it should be set to default for the background GDM.  Maybe with something like this, if possible:

if current_background = solar then
    make current background solar-hd
else
    no change
fi

Basically, the current system requires a user to install the solar-backgrounds-extras package (assuming they know it exists, otherwise do this step after complaining on forums/mailing lists).  After installing, they then have to select Solar HD as their background.  Then, to make it the GDM background, they have to click Make Default and enter the root password (a step that escaped me until I looked closer).


Version-Release number of selected component (if applicable):
solar-backgrounds.noarch                    0.91.1-1.fc10              installed
solar-backgrounds-extras.noarch             0.91.1-1.fc10              installed


How reproducible:
Current behavior after fresh install from Fedora 10 Preview.


Steps to Reproduce:
1. Install Fedora 10 Preview and set up dual monitor setup
2. Marvel at how stretched and ugly GDM and desktop background now look
3. Complain on forums/mailing lists (optional)
4. Install solar-backgrounds-extras package
5. Set Solar HD as desktop background
6. Complain some more about how GDM still looks like crap (optional)
7. Click Make Default and enter root password

  
Actual results:
In the end, all is well, but do we need to make people do all that when many users are going to want/need solar-backgrounds-extras in the end.  Live CD users can suffer if they want, but I install from DVD so I avoid this kind of thing.


Expected results:
solar-backgrounds-extras is installed and set as background by default when installing from CD/DVD install media.


Additional info:
I can fix it, true, but shouldn't it Just Work?
Comment 1 Gideon Mayhak 2008-11-07 22:00:49 EST
And I apologize for the above sarcasm, but I enjoy it :).  I have to say the Solar theme is breathtaking and made me giddy to the point of grinning giggles when the packages first came down through rawhide.  While I didn't mind Fedora 9's theme, per se, it just didn't feel as high quality as Fedora 7 or 8.  Solar is absolutely gorgeous, and I don't plan to change until Fedora 11 :D.
Comment 2 Gideon Mayhak 2008-11-16 15:35:42 EST
Any thoughts on this?  I haven't tried installing from rawhide lately, so I don't know if the situation has changed.  Is the current behavior still as I described above, or is it going to be changed/fixed for the final release?
Comment 3 Martin Sourada 2008-11-16 16:07:01 EST
Hm, I don't think we can do it. AFAIK there can be only one default. Adding dual screen wallpapers to the basic package would increase its size significantly and thus is a no-no for the live spins, overiding defaults via a package is a no-no too, shiping different "settings" package on live media and DVD install is probably out of question as well :-/ You'll just have to install solar-backgrounds-extras and set a Solar HD one to use it for your wallpaper manualy.

Note You need to log in before you can comment on or make changes to this bug.