Bug 470662 - Call to ldap.get_option crashes interpreter
Call to ldap.get_option crashes interpreter
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-ldap (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 11:14 EST by Sergio Pascual
Modified: 2008-11-08 12:20 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 12:20:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Pascual 2008-11-08 11:14:59 EST
Description of problem:
A call to
ldap.get_option(ldap.OPT_X_TLS_CERTFILE)
crashes the python interpreter

Version-Release number of selected component (if applicable):
python-2.5.1-26
python-ldap-2.3.1-3


How reproducible:
Always

Steps to Reproduce:

$ python -c 'import ldap;ldap.get_option(ldap.OPT_X_TLS_CERTFILE)'
  
Actual results:
python: Objects/stringobject.c:107: PyString_FromString: Assertion `str != ((void *)0)' failed.
Aborted

Expected results:
A string, something that doesn't break the python interpreter
Comment 1 Sergio Pascual 2008-11-08 11:23:47 EST
ldap.OPT_X_TLS_KEYFILE breaks also the interpreter with the same message.
Comment 2 Matthew Barnes 2008-11-08 11:25:02 EST
Looks like this was fixed in a later release:

  Released 2.3.4 2008-03-29

  Changes since 2.3.3:

  Modules/
  * Fixed seg fault when calling LDAPObject.get_option()
    (see SF#1926507, thanks to Matej)

Current version in Fedora 10 is 2.3.5.
Would you prefer I backport it to Fedora 9?
Comment 3 Sergio Pascual 2008-11-08 11:38:13 EST
I found this when experimenting with ldap auth in Moin. I don't use python-ldap frequently and probably I will upgrade to F10, so I think it's ok if you leave it as it is.
Comment 4 Matthew Barnes 2008-11-08 12:20:41 EST
Okay, I'll close this then and wait to backport until there's demand.

Note You need to log in before you can comment on or make changes to this bug.