Bug 470672 - Fedora 10 i686 Live Intel 845 Motherboard lockup
Fedora 10 i686 Live Intel 845 Motherboard lockup
Status: CLOSED DUPLICATE of bug 469292
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
10
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 13:04 EST by kivar
Modified: 2009-09-06 04:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-06 04:50:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
poelstra: fedora_requires_release_note+


Attachments (Terms of Use)
Xorg.0.log.intel (59.16 KB, text/plain)
2008-11-27 01:48 EST, Ví­ctor Daniel
no flags Details
Xorg.0.log.vesa-1 (33.53 KB, text/plain)
2008-11-27 01:49 EST, Ví­ctor Daniel
no flags Details
Xorg.0.log.vesa-2 (33.53 KB, text/plain)
2008-11-27 01:49 EST, Ví­ctor Daniel
no flags Details
Full html lshw report (48.92 KB, text/html)
2008-11-27 14:34 EST, Ví­ctor Daniel
no flags Details

  None (edit)
Description kivar 2008-11-08 13:04:07 EST
Description of problem:
When booting from either cdrom or usb drive,Fedora 10 Preview i686 Live
stills crashes/locks up at the autologin prompt on a motherboard using an intel845 intergrated chipset. 

Version-Release number of selected component (if applicable):
Fedora 10 Preview i686 Live CD

How reproducible:

Attempt to boot from Fedora 10 Preview i686 Live CD or live usb drive.


Steps to Reproduce:
1.See above
2.
3.
  
Actual results:
Fatal System Crash

Expected results:
Working System


Additional info:
Comment 1 Matěj Cepl 2008-11-08 19:11:25 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

When the anaconda crashes, please, switch to the console (Ctrl+Alt+F2) and cp /tmp/* to some other place -- USB stick, some other computer via network, some on the Internet, and please attach it to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 kivar 2008-11-16 11:19:20 EST
No luck. System boots untill desktop image of sun appears,
and autologin window appears, then system locks up totally,
keyboard included. Odd thing is you can move the mouse cursor 
around the screen with the mouse, but clicking the buttons does
nothing.


Only way out is to reboot the machine via the reset button
power off switch.
Comment 3 Matěj Cepl 2008-11-18 09:27:10 EST
That's Xserver crashing. Would it be possible to get to the computer from other computer via ssh?
Comment 4 Matěj Cepl 2008-11-19 19:15:40 EST
If you say "intel845 intergrated chipset" does it mean that you have intel graphics? If by chance it is ATI, you could try to put nomodeset on the kernel command line (press some arrow key quickly to get GRUB menu). Is it possible? Does it help?
Comment 5 kivar 2008-11-24 23:43:21 EST
That's Xserver crashing. Would it be possible to get to the computer from other
computer via ssh?
>
>
Unfortunely not. Machine isn't setup for networking.

>
>


If you say "intel845 intergrated chipset" does it mean that you have intel
graphics? If by chance it is ATI, you could try to put nomodeset on the kernel
command line (press some arrow key quickly to get GRUB menu). Is it possible?
Does it help?
>
>
On this machine, yes. It has an Intel based 845 graphics motherboard. It seems that only the Fedora 10 Live cd has problems with it. Fedora 9's Xserver  runs just fine on it
Comment 6 Matěj Cepl 2008-11-25 09:20:01 EST
Could you boot into runlevel 3 (add 3 to the grub kernel command line and eliminate "rhgb quiet" if present) and then startx as normal user? Could you collect /var/log/Xorg.0.log and /etc/X11/xorg.conf this way?
Comment 7 Bug Zapper 2008-11-26 00:03:32 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 John Montoya 2008-11-26 22:44:27 EST
Hello -

I have a machine with Fedora 9 on it that works fine.
Boot the live CD and having exactly the same issues - step for step.

Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device 
(rev 01)


thank you,
Comment 9 Ví­ctor Daniel 2008-11-27 01:48:06 EST
Hi,

I have exactly the same problem, using Fedora 10 Final.

Currently i'm running Fedora 10 in my machine because  i force to live (xfce spin in my case) to start in init level 3, and run the installer in text mode (with "-T" option).
To run "correctly" X server i change temporally the driver to "vesa", and thanks to that i have firefox running to write this :). But :( , in the second X server reopen (closing the session to relogin, for example) the screen put completely black, but not crashes and i can restart my box, changing to a tty session o pressing control+alt+delete.

If i delete the xorg.conf file or set to "intel" the driver or start from my burned live CD, the X server start but show ugly and crashes in 3-5 random seconds, allowing only move the cursor, and  then system locks up totally :(.

Files attached:
Xorg.0.log-intel     : Using "intel" driver or deleting xorg.conf.
Xorg.0.log-vesa-1 : Using "vesa" driver, fist X server start.
Xorg.0.log-vesa-2 : Using "vesa" driver, second X server start, for example, login out to login with other user, then screen set completely black :(.

Other bug reported related to my intel chip (in Fedora 9) : #470755

In Fedora 9 i don't have this problem.
Comment 10 Ví­ctor Daniel 2008-11-27 01:48:55 EST
Created attachment 324836 [details]
Xorg.0.log.intel
Comment 11 Ví­ctor Daniel 2008-11-27 01:49:21 EST
Created attachment 324837 [details]
Xorg.0.log.vesa-1
Comment 12 Ví­ctor Daniel 2008-11-27 01:49:42 EST
Created attachment 324838 [details]
Xorg.0.log.vesa-2
Comment 13 Ví­ctor Daniel 2008-11-27 01:54:33 EST
Note: I get Xorg.0.log.intel starting normally (without a xorg.conf), forcing turning off of my box after the crash :(, turning on, and starting in single mode (1).
Comment 14 Ví­ctor Daniel 2008-11-27 14:33:47 EST
Hardware info (using lshw):

VGA compatible controller
/0/100/2

product: 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device [8086:2562]
vendor: Intel Corporation [8086]
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities:
	Power Management,
	vga_controller,
	bus mastering,
	PCI capabilities listing
configuration:
	latency: 0

Attached full lshw-gui html report (eva-01.html).
Comment 15 Ví­ctor Daniel 2008-11-27 14:34:27 EST
Created attachment 324911 [details]
Full html lshw report
Comment 16 kivar 2008-11-30 11:49:26 EST
Hello -

I have a machine with Fedora 9 on it that works fine.
Boot the live CD and having exactly the same issues - step for step.

Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device 
(rev 01)

>
>

I'm also running into basically the same thing with the Fedora 10 live cd with the graphical install with the Fedora 10 DVD on my machine with the same intel chipset as yours.

After the DVD boots up from the boot menu and encounters the graphical install, the display turns into trash, and the computer locks up.
Comment 17 Karsten Wade 2008-12-01 15:47:27 EST
Rather than putting in a change to the release notes, I recommend putting a note with pointer to this bug and tips here:

https://fedoraproject.org/wiki/Bugs/Common

The reason is -- bugs are, ideally, short-lived, so formally documenting and translating that doc and etc. is not the first choice solution.
Comment 18 kivar 2008-12-01 22:33:08 EST
Comment #17 From  Karsten Wade (kwade@redhat.com)  2008-12-01 15:47:27 EDT   (-) [reply] -------

Rather than putting in a change to the release notes, I recommend putting a
note with pointer to this bug and tips here:

https://fedoraproject.org/wiki/Bugs/Common

The reason is -- bugs are, ideally, short-lived, so formally documenting and
translating that doc and etc. is not the first choice solution.
>
>

Ummm. This bug has been present ever since the first Fedora 10 live cd was released. 

Every fedora 10 live cd released from day 1 *ALWAYS* crashed and burned  on my machine with the intel 845 chipset and I suspect that this held true in one fashon or another for anyone else who tried running it on an machine using an intel 845 based chipset.

There was *NOTHING* short-lived about this problem, and quite frankly I suspect the only way it's going to be actually fixed is to formally document it and
translating that doc and etc.
Comment 19 Karsten Wade 2008-12-01 23:27:31 EST
(In reply to comment #18)
> 
> 
> Ummm. This bug has been present ever since the first Fedora 10 live cd was
> released. 

Note that the release notes were open via the wiki for the entire community to input content throughout the development process, right up until the week after the Preview Release was out.  After that, it is not trivial to update the notes and translations.  This is one of the reasons we setup the common bugs page and process.

> Every fedora 10 live cd released from day 1 *ALWAYS* crashed and burned  on my
> machine with the intel 845 chipset and I suspect that this held true in one
> fashon or another for anyone else who tried running it on an machine using an
> intel 845 based chipset.

Sorry, I didn't read back in the bug carefully to see this was a longer-standing problem.

> There was *NOTHING* short-lived about this problem, and quite frankly I suspect
> the only way it's going to be actually fixed is to formally document it and
> translating that doc and etc.

There really is no correlation between what is documented and what is fixed.  Ideally we don't document bugs, we fix them.  What you propose is to set a few dozen volunteers to work documenting and translating for this bug.  It is far easier and nearly as productive to put the content on the common bugs page.  If there is a need to update the release notes, we usually ask the Bug Triage/QA teams to let Docs know.

That said, I left the release notes flag on this bug so Docs can keep an eye on progress.
Comment 20 Ví­ctor Daniel 2009-01-23 17:36:03 EST
My CHIP Info:

Intel (R)
FW82801DB
SL6DM
INTEL (M)(C)'01
PHILIPPINES
Comment 21 Ví­ctor Daniel 2009-01-23 17:37:20 EST
Typo Error:
Intel (R)
FW82801DB
F3400203
SL6DM
INTEL (M)(C)'01
PHILIPPINES
Comment 22 Ví­ctor Daniel 2009-02-03 01:03:16 EST
Hi,

Adding 
Option "AccelMethod" "XAA"
to Device Section the system not crash.

The windows move very slow, but, lockup, if i enable the composite to xfwm4 the windows move fast.

I think this bug have relation to https://bugzilla.redhat.com/show_bug.cgi?id=464866. #464866

Bye and tks.
Comment 23 Vedran Miletić 2009-09-06 04:50:29 EDT
This is likely a duplicate of bug 469292.

*** This bug has been marked as a duplicate of bug 469292 ***

Note You need to log in before you can comment on or make changes to this bug.