Bug 470674 - xmessage can't find font in Unicode, and then segfaulted
xmessage can't find font in Unicode, and then segfaulted
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-apps (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 13:57 EST by Pavel Alexeev
Modified: 2008-11-12 04:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 04:52:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example core dump on locale en_US.utf8 (488.00 KB, application/octet-stream)
2008-11-08 13:57 EST, Pavel Alexeev
no flags Details
script to generate backtrace (328 bytes, text/plain)
2008-11-08 19:30 EST, Matěj Cepl
no flags Details

  None (edit)
Description Pavel Alexeev 2008-11-08 13:57:03 EST
Created attachment 322962 [details]
Example core dump on locale en_US.utf8

Description of problem:
$ export LANG=en_US.utf8
[pasha@x-www ~]$ xmessage Test
Warning: Unable to load any usable ISO8859 font
Segmentation fault

(core dump attached)

On locale ru_RU.utf8 the same behavior, except of language of message about segmentation fault.

On C locale it is only produces warnings, but works:
$ export LANG=C
[pasha@x-www amurforum_test2]$ xmessage Test
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset


Version-Release number of selected component (if applicable):
$ rpm -qf `which xmessage `
xorg-x11-apps-7.3-3.fc9.i386

$ rpm -qa '*ISO8859*'
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
Comment 1 Matěj Cepl 2008-11-08 19:30:33 EST
Created attachment 322976 [details]
script to generate backtrace

I am sorry, but it is actually by far the most simple to generate useful backtrace on your computer. Could you please make sure that you have installed yum-utils and gdb packages, and the download -debuginfo packages running

debuginfo-install xorg-x11-apps.$(uname -i)

Then run the attached script gbt like this

gbt xmessage core.1055

Script should generate file xmessage-backtrace-1055.txt. Could you please attach this file to this bug as uncompressed attachment?

Thank you
Comment 2 Pavel Alexeev 2008-11-12 00:08:19 EST
Please excuse me for long reply at this time I have huge amount of work...

I'm install all debuginfo packages and ... and can't reproduce error anymore! I even do not rebuild computer (but have xorg restarted once)

So, I can't even suppose what was a key to the problem. There exactly same versions of component.
# rpm -qf `which xmessage `
xorg-x11-apps-7.3-3.fc9.i386
# rpm -qa '*ISO8859*'
xorg-x11-fonts-ISO8859-1-75dpi-7.2-6.fc9.noarch
I'm update other software, and possibility problem has been fixed in related libraries...

So, I'm try to find problem and reproduce error again, but without success.
If I can do it, I will wrote there immediately.
Comment 3 Matěj Cepl 2008-11-12 04:52:18 EST
Thanks a lot, Pavel, for reporting the bug and taking all the effort to get us the information.

If you ever hit this again, please, feel free to reopen this with the relevant info.

Until then, I am closing this as WORKSFORME.

Note You need to log in before you can comment on or make changes to this bug.