Bug 470688 - Request for rubygems >= 1.3.0, merb uninstallable with v.1.2.0
Request for rubygems >= 1.3.0, merb uninstallable with v.1.2.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygems (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lutterkort
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 16:16 EST by Jesse Hutton
Modified: 2013-04-30 19:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-17 19:42:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec file for rubygems-1.3.1-1.fc9.noarch (3.22 KB, text/plain)
2008-11-08 19:40 EST, Jeroen van Meeuwen
no flags Details
Patch against rubygems-1.3.1.tgz for a noarch gemdir (638 bytes, text/plain)
2008-11-08 19:41 EST, Jeroen van Meeuwen
no flags Details
rubygems-1.3.1.fc9 SRPM (262.88 KB, application/octet-stream)
2008-11-08 19:42 EST, Jeroen van Meeuwen
no flags Details

  None (edit)
Description Jesse Hutton 2008-11-08 16:16:58 EST
Description of problem:

rubygems >= 1.3.0 is required for Merb, the newly released ruby web framework, and thus Merb is unstallable

Version-Release number of selected component (if applicable): all


How reproducible: 100%


Steps to Reproduce:
1. type 'gem install merb --source http://edge.merbivore.com'
2.
3.
  
Actual results: dependency error notifying of rubygems >= 1.3.0 requirment


Expected results: successful installation of merb


Additional info: I tried modifying the srcrpm for 1.2x but wasn't successful. It seems that there were some changes in the setup. I also posted to fedora-devel giving a bit more context: https://www.redhat.com/archives/fedora-devel-list/2008-November/msg00424.html
Comment 1 Jeroen van Meeuwen 2008-11-08 19:40:20 EST
Created attachment 322977 [details]
Spec file for rubygems-1.3.1-1.fc9.noarch

Attaching spec file for rubygems-1.3.1-1.fc9.noarch
Comment 2 Jeroen van Meeuwen 2008-11-08 19:41:18 EST
Created attachment 322978 [details]
Patch against rubygems-1.3.1.tgz for a noarch gemdir

Attaching noarch patch
Comment 3 Jeroen van Meeuwen 2008-11-08 19:42:04 EST
Created attachment 322979 [details]
rubygems-1.3.1.fc9 SRPM

Attaching SRPM
Comment 4 Jeroen van Meeuwen 2008-11-08 19:42:54 EST
The above has been tested only very basically (gem list, gem update, gem install).

rpmlint is silent
Comment 5 Jesse Hutton 2008-11-08 21:27:59 EST
Thanks a lot, Jeroen. Merb 1.0 installed fine and everything seems to be working well :)
Comment 6 Jeroen van Meeuwen 2008-11-09 06:13:00 EST
David, can I make this go to F-10 and devel at the very least? Please advice on whether or not to push it out to EL-5.
Comment 7 Bug Zapper 2008-11-26 00:04:18 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 David Lutterkort 2008-12-12 15:02:37 EST
(In reply to comment #6)
> David, can I make this go to F-10 and devel at the very least? Please advice on
> whether or not to push it out to EL-5.

Sorry, this bz fell into some mail filter. Yes, please push this out to F-10, devel, and EL-5
Comment 9 Fedora Update System 2008-12-13 08:00:16 EST
rubygems-1.3.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/rubygems-1.3.1-1.fc10
Comment 10 Fedora Update System 2008-12-17 19:42:25 EST
rubygems-1.3.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.