Bug 470689 - NetworkManager can't execute pppd - needed for mobile broadband connection
NetworkManager can't execute pppd - needed for mobile broadband connection
Status: CLOSED DUPLICATE of bug 465774
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 16:47 EST by Jon Stanley
Modified: 2008-11-08 16:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-08 16:59:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Stanley 2008-11-08 16:47:53 EST
NetworkManager can't launch pppd, therefore mobile broadband connections don't work.

type=SYSCALL msg=audit(1224365034.450:19): arch=c000003e syscall=59 success=no exit=-13 a0=1c5c200 a1=1c56730 a2=7fff61953660 a3=0 items=0 ppid=2346 pid=3701 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="NetworkManager" exe="/usr/sbin/NetworkManager" subj=system_u:system_r:NetworkManager_t:s0 key=(null)

type=AVC msg=audit(1224365034.450:19): avc:  denied  { execute } for  pid=3701 comm="NetworkManager" name="pppd" dev=dm-1 ino=1763556 scontext=system_u:system_r:NetworkManager_t:s0 tcontext=system_u:object_r:pppd_exec_t:s0 tclass=file

module nmppp 1.0;

require {
	type NetworkManager_t;
	type pppd_exec_t;
	class file execute;
}
require {
	type NetworkManager_t;
	type pppd_exec_t;
	class file execute;
}

#============= NetworkManager_t ==============
allow NetworkManager_t pppd_exec_t:file execute;
Comment 1 Jon Stanley 2008-11-08 16:59:10 EST

*** This bug has been marked as a duplicate of bug 465774 ***

Note You need to log in before you can comment on or make changes to this bug.