Bug 470704 - Hinting problems with default Sans font
Hinting problems with default Sans font
Status: CLOSED DUPLICATE of bug 368561
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-08 21:30 EST by Kieran Clancy
Modified: 2008-11-09 16:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-09 16:25:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Cropped screenshot of Firefox search box (2.07 KB, image/png)
2008-11-08 21:30 EST, Kieran Clancy
no flags Details
Enlarged region of font, with added colour to highlight strange hinting (2.43 KB, image/png)
2008-11-08 21:32 EST, Kieran Clancy
no flags Details

  None (edit)
Description Kieran Clancy 2008-11-08 21:30:20 EST
Created attachment 322983 [details]
Cropped screenshot of Firefox search box

Description of problem:
There seems to be some strange hinting on certain letter combinations for the Sans font in Fedora 9. This happens in the URL bar and Search box in Firefox, but it probably happens in other applications too. See the screenshots attached.

Version-Release number of selected component (if applicable):
freetype-2.3.5-6.fc9.i386
dejavu-fonts-2.24-3.fc9.noarch (I don't know if the default 'Sans' is DejaVu or if 'Sans' is from another package)
firefox-3.0.2-1.fc9.i386

How reproducible:
Every time.

Steps to Reproduce:
1. Type the letters 'fi' into the search box in Firefox
  
Actual results:
Fonts are strangely hinted, as in the screenshot attached.

Expected results:
Kerning and hinting should be consistent.
Comment 1 Kieran Clancy 2008-11-08 21:32:30 EST
Created attachment 322984 [details]
Enlarged region of font, with added colour to highlight strange hinting
Comment 2 Kevin Kofler 2008-11-08 21:36:05 EST
That's the fi ligature. I don't think it's Freetype using that ligature, but something higher in the stack, for example Qt 3 applications don't use it, Qt 4 apps do. In Firefox's case, it's probably Pango.

But I suspect the real problem is that the font appears to come with a broken fi ligature.
Comment 3 Kieran Clancy 2008-11-08 21:41:42 EST
Thanks for the quick response. I wasn't really sure what component to assign this bug to; feel free to reassign it somewhere more appropriate.
Comment 4 Kevin Kofler 2008-11-08 21:47:21 EST
I'll let Behdad do that because I'm not really sure what the right component is here (but I suspect it's either dejavu-fonts or pango).
Comment 5 Nicolas Mailhot 2008-11-09 03:04:13 EST
The font itself is fine. However it has to rely on hinting to make sure f and f ligatures are resized consistently at small sizes. Since we don't use upstream hints for evil patent reasons, the problem is in our freetype/pango autohinting logic.

And yes this bug is highly user-visible and very annoying.
Comment 6 Kevin Kofler 2008-11-09 10:41:05 EST
You're right, this is the autohinter's fault. If I turn the hinting off entirely, I get unusably blurry fonts, but the ligatures don't look misplaced. So freetype is actually the correct component to file this against (though disabling the ligatures in Pango and Qt 4 might also be a solution, we've done well for years without them, e.g. Qt 3 never used them).
Comment 7 Kevin Kofler 2008-11-09 16:25:20 EST
Turns out we already have a bug filed about this, Nicolas just reassigned it to freetype.

*** This bug has been marked as a duplicate of bug 368561 ***

Note You need to log in before you can comment on or make changes to this bug.