Bug 470732 - %post script from plymouth-plugin-solar fails
%post script from plymouth-plugin-solar fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
rawhide
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F10DesktopBlocker
  Show dependency treegraph
 
Reported: 2008-11-09 14:20 EST by Jeroen van Meeuwen
Modified: 2013-01-09 23:54 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-14 18:35:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen van Meeuwen 2008-11-09 14:20:29 EST
Description of problem:

The post script of plymouth-plugin-solar fails on x86_64 because it misdiagnoses the architecture.

Version-Release number of selected component (if applicable):

plymouth-0.6.0-0.2008.10.30.4.fc10.x86_64

How reproducible:

Run a compose with pungi or revisor or by manually running the buildinstall script against an install tree

Steps to Reproduce:
1. yum --enablerepo=development install revisor-unity
2. revisor --cli --yes --config /etc/revisor-unity/revisor.conf --model rawhide-x86_64-respin --debug 9 2>&1 | tee revisor.log
3. Note how buildinstall errors out after ~22% because scripts/upd-instroot has:

yum install foo || die "ERROR: Could not install packages"

any return value other then 0 causes the build to tail, in this case the plymouth-plugin-solar %post script (or plymouth-set-default-plugin to be more exact)

Additional info:

bash-3.2# uname -p
x86_64
bash-3.2# sh -x /usr/sbin/plymouth-set-default-plugin solar
+ set -e
+ '[' -z '' ']'
+ LIBEXECDIR=/usr/libexec
+ '[' -z '' ']'
+ DATADIR=/usr/share
+ '[' -z '' ']'
++ echo nash-showelfinterp /proc/32239/exe
++ /sbin/nash --forcequiet
++ grep -q lib64
+ LIB=lib
+ '[' -z '' ']'
+ LIBDIR=/usr/lib
+ '[' -z '' ']'
+ BINDIR=/usr/bin
+ '[' 1 -lt 1 ']'
++ id -u
+ '[' 0 -ne 0 ']'
+ PLUGIN_NAME=solar
+ '[' solar = --reset ']'
+ '[' '!' -e /usr/lib/plymouth/solar.so ']'
+ echo '/usr/lib/plymouth/solar.so does not exist'
+ exit 1
Comment 1 Jeroen van Meeuwen 2008-11-09 14:29:20 EST
Note that (from IRC):

<halfline> i'm still pretty curious what the output of echo nash-showelfinterp /proc/$$/exe | nash --quiet is
<jmeeuwen> (Sun)[20:14:20] <jmeeuwen> it returns: /proc/4017/exe
<halfline> it's outputting just that?
<jmeeuwen> yes
<halfline> as if you typed echo /proc/$$/exe ?
<jmeeuwen> yes
<halfline> sounds like nash is messed up
Comment 2 Ray Strode [halfline] 2008-11-10 16:01:33 EST
okay i gave this a hammer:

export LIB=%{_lib}
before calling 

plymouth-set-default-plugin
Comment 3 Jeroen van Meeuwen 2008-11-10 18:28:26 EST
is there a reason not to use:

%{_sbin}/plymouth-set-default-plugin %{_libdir}/plymouth/solar.so

in %post scriptlets?
Comment 4 Ray Strode [halfline] 2008-11-10 20:13:22 EST
It's not obviously better than what we're doing now.

In the future the plugins directory may change, too.

See http://bugs.freedesktop.org/show_bug.cgi?id=18298
Comment 5 Jesse Keating 2008-11-12 20:52:47 EST
The fix from comment #2 doesn't work.  moving back to assigned.
Comment 6 Ray Strode [halfline] 2008-11-12 21:12:37 EST
moving back to MODIFIED since this got fixed while we were talking on IRC this afternoon.
Comment 7 Tom "spot" Callaway 2008-11-14 18:19:41 EST
Is this fixed in a tagged version of plymouth? (If so, please state the version and close this bug).
Comment 8 Jesse Keating 2008-11-14 18:35:24 EST
I don't know exactly which version, but it's certainly fixed in 0.6.0-0.2008.11.12.4.fc10.

Note You need to log in before you can comment on or make changes to this bug.