Bug 470797 - Problem with 3D/Direct Rendering on free "radeon" driver on Xpress 200M.
Problem with 3D/Direct Rendering on free "radeon" driver on Xpress 200M.
Status: CLOSED DUPLICATE of bug 498457
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
10
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 06:16 EST by Konrad Mosoń
Modified: 2009-06-30 02:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-30 02:36:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf which worked on F9. (1.58 KB, text/plain)
2008-11-10 06:20 EST, Konrad Mosoń
no flags Details
xorg.conf which works on Slackware on my friend's computer. Don't works for me. (2.39 KB, text/plain)
2008-11-10 06:21 EST, Konrad Mosoń
no flags Details
/var/log/Xorg.0.log (67.49 KB, text/plain)
2008-11-10 19:19 EST, Matěj Cepl
no flags Details

  None (edit)
Description Konrad Mosoń 2008-11-10 06:16:13 EST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.2) Gecko/2008102718 Fedora/3.0.2-1.fc10 Firefox/3.0.2

There's no 3D acceleration on my Radeon Xpress 200M graphic card. I was (simply but usable) 3D on Fedora 9 with my tuned up xorg.conf.

I asked somebody with Slackware, and he have glxgears about 2000fps and on Fedora 10 i have only about 100fps... I copy from him xorg.conf and changed it for my system, but i really don't have 3D.



Reproducible: Always

Steps to Reproduce:
1. Get Xpress 200M.
2. Use "radeon" driver on F10.
3. You can use my tuned up xorg.conf, or accept to X try auto-configure with no xorg.conf.
4. Run glxgears -info, and glxinfo.
Actual Results:  
$$ glxgears -info
GL_RENDERER   = Software Rasterizer
GL_VERSION    = 1.4 (2.1 Mesa 7.3-devel)
GL_VENDOR     = Mesa Project
GL_EXTENSIONS = (Here some informations about driver extensions)
1018 frames in 5.0 seconds = 203.273 FPS
1020 frames in 5.0 seconds = 203.552 FPS
1020 frames in 5.0 seconds = 203.183 FPS
1000 frames in 5.0 seconds = 199.175 FPS
1000 frames in 5.0 seconds = 198.937 FPS

$$ glxinfo
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
(Here some more informations about GLX extenstions, etc...)
OpenGL vendor string: Mesa Project
OpenGL renderer string: Software Rasterizer
OpenGL version string: 1.4 (2.1 Mesa 7.3-devel)
(Here some more informations about OpenGL extenstions, etc...)

Expected Results:  
$$ glxgears -info
GL_RENDERER   = Radeon Xpress 200M
GL_VERSION    = /Here i don't know, but something about version of radeon driver/
GL_VENDOR     = /I don't know/
GL_EXTENSIONS = (Here some informations about driver extensions)
13638 frames in 5.0 seconds = 2727.520 FPS
13872 frames in 5.0 seconds = 2774.218 FPS

$$ glxinfo
direct rendering: Yes

I try run glxinfo with LIBGL_DEBUG=yes and i have this result that program can't open /dev/dri0 (or something, now i'm on fglrx (also didn't work 3D), i correct result of this value when i changed driver)

I add as attachment my xorg.conf which "works" on F9, and xorg.conf from person who using Slackware and have better results on this graphics card.
Comment 1 Konrad Mosoń 2008-11-10 06:20:00 EST
Created attachment 323056 [details]
My xorg.conf which worked on F9.
Comment 2 Konrad Mosoń 2008-11-10 06:21:02 EST
Created attachment 323057 [details]
xorg.conf which works on Slackware on my friend's computer. Don't works for me.
Comment 3 Konrad Mosoń 2008-11-10 06:40:00 EST
Updated info:

$$ LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 5.3.0 r300 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/r300_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:05.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:01:05.0
libGL error: drmMap of framebuffer failed (Invalid argument)libGL error: reverting to software direct rendering
libGL: OpenDriver: trying /usr/lib/dri/swrast_dri.so
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
(more info about extensions)

$$ glxgears 
808 frames in 5.0 seconds = 161.486 FPS
817 frames in 5.0 seconds = 163.280 FPS
790 frames in 5.0 seconds = 157.969 FPS
807 frames in 5.0 seconds = 161.270 FPS

####
Sorry, for bad results on first commit. I forgot that there's fglrx results.
####

glxgears is run with default window size... Well... this results isn't so good.
Comment 4 Konrad Mosoń 2008-11-10 07:04:01 EST
Next update: I got some warnings on Xorg.0.log:

(WW) RADEON(0): DRI init changed memory map, adjusting ...
(WW) RADEON(0):   MC_FB_LOCATION  was: 0x3fff3800 is: 0x3fff3800
(WW) RADEON(0):   MC_AGP_LOCATION was: 0xffffffc0 is: 0x41ff4000

I've got this warn twice.
Comment 5 Matěj Cepl 2008-11-10 13:17:05 EST
Can we get /var/log/Xorg.*.log attached to this bug as well, please?
Comment 6 Konrad Mosoń 2008-11-10 15:55:02 EST
Here is Xorg.0.log: http://pastebin.ca/1250994
Comment 7 Matěj Cepl 2008-11-10 19:19:34 EST
Created attachment 323137 [details]
/var/log/Xorg.0.log

We prefer to have all evidence inside of our bugzilla.
Comment 8 Dave Airlie 2008-11-12 01:29:06 EST
are you booting with nomodeset? does DRI work with modesetting enabled?
Comment 9 Konrad Mosoń 2008-11-12 08:29:21 EST
I'm booting with "nomodeset".

With kernel modesetting (without "nomodeset") DRI also works, but there's also problem with /dev/dri there's a results:

$$ LIBGL_DEBUG=verbose glxinfo
name of display: :0.0
libGL: XF86DRIGetClientDriverName: 4.3.0 r300 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/r300_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:01:05.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:01:05.0
libGL error: 
Can't open configuration file /etc/drirc: No such file or directory.
libGL error: 
Can't open configuration file /home/morsik/.drirc: No such file or directory.
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2

$$ glxgears -info
GL_RENDERER   = Mesa DRI R300 20060815 x86/MMX/SSE2 NO-TCL
GL_VERSION    = 1.3 Mesa 7.3-devel
GL_VENDOR     = DRI R300 Project
GL_EXTENSIONS = /here GL extensions/
834 frames in 5.0 seconds = 166.782 FPS
767 frames in 5.0 seconds = 152.108 FPS

But... there's a lots of problems with kernelmodesetting... I will do another bug about this.
Comment 10 Bug Zapper 2008-11-26 00:07:06 EST
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Matěj Cepl 2009-06-30 02:36:12 EDT

*** This bug has been marked as a duplicate of bug 498457 ***

Note You need to log in before you can comment on or make changes to this bug.