Bug 470802 - [RFE] Adding a properties field to application in the menu.
[RFE] Adding a properties field to application in the menu.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-menus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 07:01 EST by Jóhann B. Guðmundsson
Modified: 2009-02-05 15:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-05 15:59:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jóhann B. Guðmundsson 2008-11-10 07:01:21 EST
Description of problem:

Now if a user selects an application and does a right click
he has no chance of seeing what's being executed hence he has
no easy way to identify to which package the application belongs hence 
he either cant remove it or file a proper bug report against the right
component...

For example click Application select Accessories right click 
on Archive Manager and I get only Add this launcher to panel, Add this launcher to desktop and a Entire menu so me as I novice desktop user think ok let's search for Archive Menu in the filesystem and I have no results what's over which is perfectly normal since file-roller is being executed...

Now this leads to the end-user being confused and file a bug against Gnome..

It would be extremely useful to have components "properties" that would show
what's being executed which permission and SElinux context the file has along with to which package the file belongs to.

This would lead to better user experience along with bugs get filed against
the correct component.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthias Clasen 2008-11-10 12:58:56 EST
If you want something like that, it would be much better to do what Ubuntu does, and patch some "Report a bug" menuitem into the help menu of each application.
But that is a lot of work, and those patches need constant updating...
Comment 2 Jóhann B. Guðmundsson 2008-11-10 13:39:10 EST
Hum.. 

If i'm understanding you correctly then you are saying that Ubuntu adds a bug reporting tool into the help menu of each app...

Smart you think? 

If the app is failing to run how are you going to access the "Report 
a bug" menu item that's in the help menu of the failing app?

You realize that things get invented, bugs get fixed ( opposed to hack to work ) and sane solution found to problems happens in Fedora not Ubuntu. 

Kidney's man kidney's....


Properties would just show $path with 
permission along with rpm -qf $path to show what 
package it belongs to and it's the same code base to 
whatever app is added to the menu...

Simple efficient and provides the tester with the info that he needs to 
file a bug report against the correct component and actually works 
encase the app crashes when starting..
Comment 3 Matěj Cepl 2008-11-28 13:15:23 EST
OK, interesting discussion, but nothing to triage here.

Switching to ASSIGNED so that developers have responsibility to do whatever they want to do with it.
Comment 4 Matthias Clasen 2009-02-05 15:59:39 EST
"Application not starting at all" is not a regular scenario that we should design the ui around... total breakage is (hopefully) the exception, not the norm. A "Report a bug" menuitem inside the menu will work ok in the overwhelming majority of cases.

Note You need to log in before you can comment on or make changes to this bug.