Bug 470806 - Xorg crashes caused by DRM failure
Xorg crashes caused by DRM failure
Status: CLOSED DUPLICATE of bug 464896
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-10 07:37 EST by Peter Reuschlein
Modified: 2008-11-12 12:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-12 12:15:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
DMESG output after the crash (41.45 KB, text/plain)
2008-11-10 07:37 EST, Peter Reuschlein
no flags Details
message log output (5.74 KB, text/plain)
2008-11-10 07:37 EST, Peter Reuschlein
no flags Details
Xorg config file (868 bytes, text/plain)
2008-11-10 07:38 EST, Peter Reuschlein
no flags Details
Xorg logfile (87.09 KB, text/plain)
2008-11-10 07:38 EST, Peter Reuschlein
no flags Details

  None (edit)
Description Peter Reuschlein 2008-11-10 07:37:03 EST
Created attachment 323062 [details]
DMESG output after the crash

Description of problem:
When opening a special web page, my Xorg crashes to the ground. Reproducible at this webpage -> http://lichking.buffed.de/talentplaner/byclass/3029061_6 (yeah WoW don't blame me ;)
dmesg shows something like
[drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
[drm:drm_buffer_object_validate] *ERROR* Out of aperture space or DRM memory quota.
[drm:drm_buffer_object_validate] *ERROR* Failed moving buffer.
[drm:drm_buffer_object_validate] *ERROR* Out of aperture space or DRM memory quota.



Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.5.2-12.fc10.i386
xorg-x11-drv-ati-6.9.0-38.fc10.i386


How reproducible:
Open the Website above, perhaps click around (may also just be a local problem here
  
Actual results:
Xorg crashes

Expected results:
Talent Calculation for my paladin ;)

Additional info:
Comment 1 Peter Reuschlein 2008-11-10 07:37:41 EST
Created attachment 323063 [details]
message log output
Comment 2 Peter Reuschlein 2008-11-10 07:38:06 EST
Created attachment 323064 [details]
Xorg config file
Comment 3 Peter Reuschlein 2008-11-10 07:38:25 EST
Created attachment 323065 [details]
Xorg logfile
Comment 4 Yanko Kaneti 2008-11-10 10:22:20 EST
This sound very much like 468571
Perhaps you can upgrade to xorg-x11-drv-ati -44  and kernel 2.6.27.5-92 from koji and see if they fix the problem for you.
Comment 5 Matěj Cepl 2008-11-10 13:26:41 EST
Yes, reporter, does upgrading to the latest koji build help?
Comment 6 Peter Reuschlein 2008-11-11 03:54:57 EST
Hi Matej / Yanko, 

sorry took me some time to get my system working again :)
xorg-x11-drv-ati -44  and kernel 2.6.27.5-92 make the situation even worse. 
When having both, as soon as the login screen pops up, the system restarts. 

When using the old kernel with the xorg-ati driver the kernel panics during startup. 

I needed to downgrade to the current rawhide release of xorg-x11-drv-ati to get the system working again.

I will have a look if i can provide more information. But as i need this laptop i didn't had the time to do some deeper testing. 

regards
Peter
Comment 7 Matěj Cepl 2008-11-11 08:15:36 EST
Does nomodeset on the kernel command line (i.e., in /boot/grub/menu.lst) help?
Comment 8 Peter Reuschlein 2008-11-12 10:17:19 EST
Hi, 
changed to -44 xorg-x11-drv-ati and 2.6.27.5-94 + added the nomodeset parameter. 

That helps thanks. 

Also improves the performance of the system by feeled 200%

regards
Peter
Comment 9 Matěj Cepl 2008-11-12 12:15:41 EST

*** This bug has been marked as a duplicate of bug 464896 ***

Note You need to log in before you can comment on or make changes to this bug.